Alfa Romeo Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
2,736 Posts
Discussion Starter #1
hello all, i just joined up so thought i would introduce myself.

im 20, from the UK and have been driving the 147 2.0 sincec december now, ,wasn't my first choice of car, i did have a celica 190 but unfortunately that got smashed into (give way signs are aparently optional advice now).

since buying the 147 ive had a few things done to the engine, and have had a nightmare with the front suspension, wihshbones grrr!

engine wise ive got the following

fast road cams
matched ports
polished inlet manifold and TB
custom CAI
ECU Re-map

187bhp
219Nm torque
best 0-62mph (0-100kmh) 7.4secs

MUST get new exhaust on it, im determined to hit 200bhp with this N/A engine.

pics:

 

·
Registered
Joined
·
2,736 Posts
Discussion Starter #3
so far im impressed. drives brilliantly , and with the mods its just as quick as the celica was! had problems with the lower wishbone tho, had it replaced and its now developed a squeak, ive literally just drowned it in WD40 (as suggested on another forum) so time will tell... overall, nice car
 

·
Registered
Joined
·
7,669 Posts
Hi Marko - welcome to AO!

You have my sympathy regarding your Celica.... It's a nice car which can be transformed into a very rapid & stable road car with a few mod's.

Anyway, you seem to have minimised the pain via your 147 :)

AM
 

·
Registered
Joined
·
7,218 Posts
Hi Marko - welcome to AO :)

Sad to hear about the Celica - I had to wait till I was a lot older than 20 to get mine, but it was worth the wait. Completely different driving to an Alfa - but didn't you just love the extra power that kicked in at 6,500 revs :D
 

·
Registered
Joined
·
3,067 Posts
hello marko, pleased you are getting your car sorted, nothing like a few teething problems, good pics, whereabouts in the motherland were they taken?
 

·
Registered
Joined
·
2,736 Posts
Discussion Starter #7
the photos were actually taken by the previous owner, north yorkshire i believe, i liked them so much i kept them!
 

·
Registered
Joined
·
5,179 Posts
If you have left the 2.0L badge on it it will suprise a few people I am sure.

Come to think of it, even if you have taken the badge off it will suprise a few people :)

Cheers,
TB
 

·
Registered
Joined
·
2,736 Posts
Discussion Starter #10
trailbraker... it only has the 'selespeed' badge on the back, nothing anywhere to suggest what engine it has. i like it that way :)
 

·
Registered
Joined
·
8,063 Posts
Welcome to AO.....good to see some nice traditional mods.

Suspension.....yep it can be a problem. I'm not sure that WD40 is the best thing for the rubber bushes but it should stop the squeaks for a while. Silicon spray is supposed to be better but I can't find it here (something else for my shopping list!!)

You also need to watch the anti roll bar drop links - these wear out very quickly and knock over every bump - cheap to replace though. The bushes for the ARB will also squeak so some spray around them should help but they are hard to get at successfully.
 

·
Registered
Joined
·
2,736 Posts
Discussion Starter #15
mods so far have not cost me anything ;) all done for a mates promotional benefits!

i know a few of the prices for the gear but not them all, i dont ask when im getting for nowt! i know the cams are £450 and the CAI was £160, not sure about the other work. ill post some engine bay shots later, although it looks almost stock, except for the cai which looks discreet, doesnt sound it tho!

i've just had the drop links replaced as they were knocking like mad, fixed the problem for a whilst but now its back, im going to lube them up good a bit later, or more likely, next week, im knackered right now!
 
1 - 15 of 15 Posts
Top