Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
Hi guys, so nice to see others appreciating their Alfa's. Ok so heres my story, I bought my 156 about 6 months ago a 2.5v6 ofcourse and have loooooved driving it, best car ive ever owned (even if i did have to put new discs and pads on when i first got him).

Anyway, stupidly stupidly *punches self* i had to do a manual ecu reset on the first day of the snow. (think the gf left the radio on overnight and the battery went flat) so ive spent nearly 2 hrs disconnecting the battery reconnecting it engine on, off etc and then i took my beloved 156 out. well 5 mins later I bumped into a KA and my poor Alfa looks so sorry for himself and worst of i bet the insurance will write him off :cry: .

hopefully the pic will have uploaded and you can see the damage I so wrongfully caused.

Any help or suggestions would be greatly appreciated.
Regards,
Julian
 

Attachments

G

·
Ouch! Don't worry too much Julian. Now that you know what you like just get another one and hang about on here. Welcome, btw. :)
 

·
Registered
Joined
·
149 Posts
Discussion Starter #3
Thanks Rewe, but i've told the insurance i want the car back no matter what i'll get it repaired one way or another but it will probably cost a small fortune...or a big one come to that!
 

·
Registered
Joined
·
12,861 Posts
Hi Julian and welcome to AO, sorry to hear about the accident, hope you manage to get something sorted with your insurance.......:rolleyes:
 
1 - 6 of 6 Posts
Top