Alfa Romeo Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi everyone,

Ive now had my alfa 147 for a month. I cant fault it to drive, (its amazing)but have already experienced too many problems.

Bought off a small independent dealer, 50k. he said it just had cambelt and routine service done.

Heres whats gone wrong:

-Fuel leaking from line going into the engine from a loose clip.
-Sidelight gone
-chipped windscreen
-slow electric window
-random hilarious electric problems

The main thing though is the manifold, where its connected to the cat, 2 of the 4 studs have broken causing a gap and the ususal rasping sound.

Tried speaking to the dealer, at first he tried to fob me off, now hes not taking my calls. This has proved really frustrating although i do love the car itself.

Does anyone know if i might have a case with trading standards or the like, i just feel at the moment as if ive been connned.


Sorry to start off my alfa days on a downer, but surely things will look up (please tell me they wil!!).

Any advice much appreciated......Thanks and hello!
 
M

·
Guest
Joined
·
0 Posts
Welcome to AO.com:) Got a chip in my windscreen after 2 weeks of ownership:mad:
 

·
Registered
Joined
·
6,314 Posts
You could try a solicitor's letter. The fuel leak alone shows that it was not fit for service. I've had Alfas for 14 years now and you'll soon get the problems sorted. Get the chip done for free if you have comprehensive insurance. Electric faults are often poor earth or poor battery related. Window might be better if you use some rubber lubricant on the runners, you can get it from Halfords. Where has the sidelight gone? If its a lamp/bulb just change it, shouldn't be too difficult. As you say, the driving of an Alfa makes up for most of the problems.
 

·
Registered
Joined
·
16,710 Posts
Hi, sorry to hear about your problems :)
 

·
Registered
Joined
·
2,937 Posts
Are you fully comp? If so, it wont cost u anything to get the chip in your windscreen fixed by autoglass.

There was a chip in the windscreen of my 147 that I spotted during my test drive from the dealership, but I was so smitten by her I said I'd buy her if they agreed to repair it - which they did, and did a fine job - hardly notice it at all, and was much preferable to replacing the screen.

Welcome to AO by the way! hope ya get all your other wee probs sorted.

Sorry Armoore - just realised you gave same advice. Doh!
 

·
Registered
Joined
·
33,643 Posts
Welcome to AO. :)
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
Thanks!

I guess when you break down each problem, it doesnt seem so bad...

(just discovered why sidelight dont work- cover on the back of headlight is broken and now there is condensation! yipeeeee another problem!)
 

·
Registered
Joined
·
43,564 Posts
Hello and Welcome !! :)
 

·
Registered
Joined
·
1,807 Posts
Sue the filthy kecks off the b...... or take out a large Hate Ad in the papers he advertises in?
 

·
Registered
Joined
·
32,440 Posts
hello and welcome, sorry you are having problems but get them sorted and enjoy your car. :)
 
1 - 14 of 14 Posts
Top