Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
160 Posts
Discussion Starter #1
Right, been having throttle body problems for about two years now, ya know the ones that come and go? After having error codes reset at the garage and at home via the ECU reset trick (found on here) This time round she finally packed up for good!
So new pedal assembly and throttle body and one empty bank account later and she's all ok!
So one week later whilst caught in traffic, trying to creep around a roundabout, Volvo in front decides to slow even more. Forcing me to slam into first and oopps!?
Foot down into motorway services and as before rev counter needle moving but power not delivering? I went and had a bite to eat, returned to my 156, started her up and 2000 rpm tick over! So original problem was back!
I drove along the motorway to the next services and tried the ECU reset trick again, but as expected, didn't work? Took off expecting it to settle, but in traffic now and overheating iminent!? So RAC now. Plugged in his OBD 2 reader do da? and 9 error codes came up!
Ones I can remember were pedal position, throttle body, ignition coil and most of the others were manufacture codes? so all were cleared, but now I'm waiting for the trouble to return.
Question is what should I do now? Do I have an incurable problem? Should I have an engine remap? What? :confused:
 

·
Registered
Joined
·
1,928 Posts
just out of intrest when u do reset do u do throttle reset.......thats putting key in after u reconect battery, turn MAR for 90 seconds then turn of for 90 before starting the car and leaving it running etc?

Gary
 

·
Registered
Joined
·
160 Posts
Discussion Starter #4
Yes Gary. In most cases i've disconnected the battery overnight or the minimum 1 hour then 90 secs on MAR 90 secs off then run engine without touching pedal for 10 mins or sometimes 15. Then drive in a variety of styles.
When it went wrong at the weekend during the engine running period i could tell there and then that 15 mins of engine running weren't going to cure it? (Mainly because engine sound was really inconsistent and very low revs?)Tho RAC sorted it?...
 

·
Registered
Joined
·
1,928 Posts
it doesnt make sense to me......its wierd.......have u had a auto electrician look at the motor? when u banged it in first to slow down.........if i read that bit correctly.....the engine will have lurched forwards maybe pulling a cable? parting a conector? or maybe u have a broken wire..........id assume it wasnt related to the parts u changed as the chances of the exact same thing happening are extreme....!!!!

maybe worth phoning one and see what he says.....i was at wits end once tying to sort a problem.........auot electrician found it in no time........a broken earth on wipers

Gary
 

·
Registered
Joined
·
7 Posts
I have the same problem with this car,it has lost all power and nowbody can fix it...I like to try with this throttle reset but I dont know what is that MAR meaning...Can you tell me,I like to try....thanks
 

·
Registered
Joined
·
160 Posts
Discussion Starter #7
Yep MAR is the place where you turn your key so the dash lights up and ya radio may come on for example, but engine isn't started:)
p.s Gary Yeah my garage I use are auto electrician specialists, I have had no probs since, but fingers crossed for now....?
 
1 - 7 of 7 Posts
Top