Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5,227 Posts
Discussion Starter #1
Hello All,
Managed to crack the sump this morning . Not sure how as no pot holes or speed bumps. Anyway its cracked.

So I am now trying to source a new one.
I've read its unique to the 166 which is a bit of a pain as there are plenty of other twinspark sumps around.

So if anyone has one spare I'd be greatful if they would part company with it for cash.

Thanks very much all.

Regards
Scott
 

·
Registered
Joined
·
1,410 Posts
Its probably right that the 166 sump differs from the 156 2,0 TS sump - they have different parts no.
In your case I'll ask an Alfa specialist if the 156 or CTV/Spider 916 (they have different part no, too - 7 in all for 4cyl. versions) can be made to fit.
Otherwise auto dismantlers all over Europe. They have a common data base for parts or ebay all over, too. No dought most 166 2,0 was sold in Italy.
Good luck.
 

·
Registered
Joined
·
5,227 Posts
Discussion Starter #3
Well i've found one in Germany. The sump has a slightly different carrier for the rear driveshaft bearing I'm sure of it. Least when I looked it looked different to the 147 I had. So I think its just a 2.0 Twinnie part special to the 166.

I guess welding it might be an option. But I would have to find a TIG welder.

https://www.dropbox.com/sc/nsjnfo1r1ege2ea/AADDUA3_UmkxT_gikTcp197oa
 

·
Registered
Joined
·
9,563 Posts
Pretty sure I've got one Scotty - 166 sump definitely unique to it.......
 

·
Registered
Joined
·
5,227 Posts
Discussion Starter #5
Well taken it off and looked at it. Crack runs through the high part of the sump. Taken it to be welded tomorrow.

Gladly purchase one from you if you do have a good one. The only one I can find currently is in Germany.

So if you do have one you'd be a bit of a life saver.

I did decide to take a quick look at the big end while its all exposed. All seems okay there thank god.

Fortunately the oil pump in the ts suts very low and looked clean with about three litres of oil left in.

The sump on the 166 looks quite a bit bigger and deeper than the others ones ive seen.

Still a bugger to remove though.
 

·
Vendor
Joined
·
46,348 Posts
Bad news, at least you got it sorted though. As it turns out, I don't have one in stock. They might have had one at Bedfordshire branch but looks like you're sorted now anyway. Sorry I didn't reply sooner, I've got a technician on paternity leave at the moment and I'm flat out busy in the workshop.
 

·
Registered
Joined
·
5,227 Posts
Discussion Starter #8
No worries Dan.
Well see if its still there. I might need it if this weld doesn't hold up.

Hope it does mind. Can't keep paying welding prices!
 

·
Registered
Joined
·
9,563 Posts
Found mine and sent a PM with pix. Let me know if needed. Weld "should " be OK, though!
 
1 - 9 of 9 Posts
Top