Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
200 Posts
Discussion Starter #1
p0134 Sensor Circuit No Activity Detected (Bank 1 Sensor 1)

p0430 Catalyst System Efficiency Below Threshold (Bank 2)

p1131 Lack Of HO2S Switch - Sensor Indicates Lean

p2240


It’s on a 156 2.0 jts which has been sometimes underpowered like a hesitant fault. Would these codes point to one of the lambda sensors?

I also noticed that the intake temp is 69f which it defiantly isn’t its flipping freezing here the temp gauge in the car said 43f! Could this mean that the MAF is not reading right?

would be really grateful for your comments..:thumbs: :confused:


Oh and how cool are these scanners, I am using scantool at the moment does anyone recommend any other software.

I have reset the engine light now to see if the faults pop up again, the car defiantly does not perform right though.
 

·
Banned
Joined
·
9,721 Posts
It's pointing towards a Lambda, and as you look at the engine from the front it's on your right in the downpipe.
 

·
Banned
Joined
·
9,721 Posts
If you unplug it and read the codes again it should come up with bank 1 probe 1 no heater. That wil show you that your on the right probe.
 

·
Registered
Joined
·
200 Posts
Discussion Starter #4
is that the one with the wire going to it that looks like a after thought it looks like it gets hot and in a dodgy position?:rolleyes: Alfa:lol:
 

·
Registered
Joined
·
7,032 Posts
sensor and/or MAF
 

·
Registered
Joined
·
200 Posts
Discussion Starter #6
ok i went for a 160 mile drive yesterday after clearing codes and got the p2240 and p1131 almost straight away, and a system fault under the lambda sensor saying o2 sensor possitive current controle circuit/open , so i took all the connectors to the lamba sensors apart cleaned them and slightly bent the pins to make a better connection, then i cable tied the connectors as far as possible away from heat.

The car is now perfect the hesitation/flatspots have gone and i have done over 50 miles and the fault codes are still clear.

i would recommend every one with the problems i have had just to clean up these connectors before spending money on new MAFs and Lambda sensors.

Well chuffed as you can probaly tell!!:p
 
1 - 8 of 8 Posts
Top