Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Hi all. I'm on a scheduled stop in a motel room halfway between Sydney and Adelaide, driving my newly purchased Phase 1 GTV V6.

Coolant levels when we left were fine, and the car ran quite cool (a little above 50) for the whole 800km's so far today, until we pulled into the town we're in now, it started climbing fairly rapidly. Pulled into motel, and coolant is boiling, overflowing etc...


Any suggestions or ideas here? Thermostat? I have another 500km's to do tomorrow.

Thanks
 
G

·
Did the coolant level drop? (leaky radiator or hose)
Did the fans come on? (bypass the switch)
Thermostats tend to fail in the open position bur it is only three nuts and an awkward hose clip (replace with a jubilee clip) to whip it out if you want to eliminate it for your drive tomorrow.
Don't let it get so hot you lose a head gasket. That is a lot of work, about £1200 here, so convert that into $ and add a lot if you were tempted to risk it.

I'd guess at a leaky radiator, quite common, fairly cheap and not too hard to change.

Best of luck and let us know how things turn out.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
Coolant level dropped to almost nothing as it boiled once I pulled over. Fan was on.

Spoke to previous owner, has advised that at a mechanic visit 2 days ago the engine was overheating at idle due to heater pipe to firewall leak. He modified the heater hoses to bypass the heater core. I don't quite know what to make of this?

My heater isn't working and the engine temp was between 50 and 70 for the whole 800km's until right when it was time to stop (lucky).

Perhaps it is just a leak and I can limp the remainder of the way with a stockpile of coolant? I'm in the middle of nowhere which doesn't help.
 
G

·
Sounds like it could be something simple then. Have you got a petrol station near you that may have something you could use to repair the split hose? Any staining in the foot well to indicate a leaky heater matrix/tap? Could be the reason for the initial bodge.
 

·
Registered
Joined
·
2,852 Posts
My heater isn't working and the engine temp was between 50 and 70 for the whole 800km's until right when it was time to stop (lucky).
Isn't that a symptom of a knackered radiator and the fins disintegrating? When moving the air flow keeps the temperature in check but once you've stopped, radiator can't cope and it overheats.
Sounds like the stat needs changing too.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #7 ·
Thanks for replies. Made it home!

Mechanic had turned the pipe from thermostat to heater straight back into the block, a tight turn, so the hose eventually split: coolant leak then overheat.

Hoses plugged and got home. Now for a proper fix.

Car ran great otherwise, although some typical alfa issues. Passenger door won't open from the inside 4/5 times, need to figure out the alarm system, seems the hazards flash continually until you start. The standard fit radio (in australia, with inbuilt GPS) is stupidly fiddly to use so will need to replace this.

Will post pics when its had a wash and detail.
 
1 - 7 of 7 Posts
Top