Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Dear all
I come to the forum freaking out about my 2002 147 Sele (done 175000 ks).

Recently I've been having these problems:
- loss of power, especially when accelerating
- engine makes a crackling sound when under heavy load
- fuel economy has gotten significantly worse

After doing some research the potential causes appear to be either a failed MAF sensor or the car needing new spark plugs, and I was planning to get both checked out and whatever needs to be fixed at service time in the next few days.

However since yesterday in city driving I've also had:
- smoke coming from the clutch
- the whole engine vibrating before grinding to a stop, and i've had to turn it off and restart.

I feel like this is a clutch problem, but is it a matter of an adjustment or (please god no, this is my daily driver and I'm a bit financially strapped right now) needing a full replacement? Or just more sensor issues?

Thanks in advance, I just want to know what to expect before I take it to the mechanics.
 

·
Registered
Joined
·
846 Posts
Certainly the MAF or spark plugs can cause bad running, fuel economy etc. You can unplug the MAF and see if the acceleration improves although it might not idle however the other symptoms are more concerning. Given what you say and the mileage/age of the car I'd not be surprised if the clutch (probably the release bearing) is failing.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Certainly the MAF or spark plugs can cause bad running, fuel economy etc. You can unplug the MAF and see if the acceleration improves although it might not idle however the other symptoms are more concerning. Given what you say and the mileage/age of the car I'd not be surprised if the clutch (probably the release bearing) is failing.
Thanks for your help. If it is the release bearing. how long/expensive a fix is that?
 

·
Registered
Joined
·
846 Posts
Its a gearbox off job so fairly lengthy, more so than a manual box as the actuator has to be removed first.

A genuine selespeed clutch in the UK is around £120 or so but the fitting will be a good few hours. Its also probably one for an alfa specialist or at least a garage used to dealing with selespeeds.
https://www.shop4parts.co.uk/?name=store&op=Results&keywords=71739645

You will probably need to also account for new gearbox fluid and selespeed fluid, probably another £30 or so
https://www.shop4parts.co.uk/?name=store&op=Details&ProdID=1161&sku=57397

Someone from Aus may be in a better position to advise on labour costs .

Once the clutch is installed and gearbox on it will need the clutch rod adjusted and the gearbox calibrated with Examiner, MES or other appropriate software.
 
1 - 5 of 5 Posts
Top