Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
After working through several issues with my 1996 Phase 1 GTV the last one on my list was replacing the saggy vinyl headlining with a black Phase 3 one complete with black grab handles and sun visors. That was simple enough but on reconnecting the central dome light I heard a buzzing coming from the fuse box beneath the steering wheel. Tried clicking the map light on etc but nothing. Everything worked fine before. Quickly disconnected again, checked wiring, only 2 connections so can't do it wrong. Fitted again, no buzzing this time but lights still not working. Fix another day I thought as needed to go out. Screwed it back in place anyway and left it over night. Monday morning when leaving for work the battery is flat. Worth pointing out I replaced the battery 2 weeks ago with a new Lucas one. Completely and utterly flat. Couldn't even work the boot release in the glove box which from past experience have managed to if the battery has just a little juice left if not enough to start the engine. Anyway, recharged the battery and fitted tonight. Car starts now obviously and tried fitting the dome light again and also a spare one I had from a previous GTV. Still nothing but when I turn the map light on the footwell lights come on! I'm thinking as it was a sunny day on Sunday I couldn't see they were on so that explains the battery drain but surely the fault lies elsewhere if two seperate dome lights don't work anymore. Could it be a relay? Does that explain buzzing sound? Worth pointing out too I can no longer adjust the clock time in the 3 gauge cluster. It's the first thing I did when hooking up the freshly charged battery. I know these things are all linked but does anyone know what I should be checking next??? Thought I was doing the car a good deed and this is how it repays me! Also, I have 3 wires hanging down from the rear view mirror but the dome light only has 2 connections! Is the third one a relic from the old alarm being removed? Sorry for the graphic novel.
 

·
Registered
Joined
·
2,959 Posts
if it was me i would remove the roof lining and re trace all my previous steps.......... seems reasonable to think as it was fine before that its something thats giving you this problem from your recent headlining, Having done this job myself i would carefully look over the wiring that goes to the dome light the buzzing and the battery drain is probably live touching an earth, carefully look over the wires going up the A pillar to the roof and map lights

multimeter would be good too
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Yes you were right, thanks! After thinking I had a major wiring issue on my hands I tried cleaning the contacts on both parts of the dome lights and in different combinations (I've got 2 - one spare which must have a fault on the first part) and hey presto everything working correctly. So if anyone else is having problems with their clock, electric aerial, trip meter resetting on start up, interior lights etc maybe try replacing your dome light for the sake of £10 as it's linked to many other things. I just need to dye my grey carpet black now and add the Pininfarina badges (that weren't put back after respray) and it's done ready for the Alfa Show at Chatsworth in July. I'm just glad I've kept another Phase 1 looking immaculate and more importantly on the road! Will keep this one now (I've spent enough) and hope prices rise over the next few years...they can't get any lower surely? Has anyone been to the Alfa Museum in Milan? Getting married in 3 weeks in Umbria and wife to be actually suggested we go in way to Como! I went years ago during a road trip with a friend and we arrived on the day it closed for renovation! Would love to go in the GTV but trusty Land Cruiser better for peace of mind.
 
1 - 3 of 3 Posts
Top