Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
837 Posts
Discussion Starter #1
I have been on here some time, had a 164 12v cloverleaf, a 166 3.0 sportronic and had a spell away with some other marques and now back in the fold with T reg 2.0 twin spark GTV.

It is a nice little car it is lusso spec, so has the 'ribbed' leather seats etc. Has done 85k with some history with it. I picked up the car very, very cheap as being red it has faded like most do but the previous owner decided to use rattle cans rather than polish it up! :( :cry: So it is a rather matt red currently, hoping i will be able to cut this back and get at the paint but time will tell.

It has a noisey release bearing on the clutch and the usual airbag light is on as well as the idle seems to hunt quite a bit, but will clean the idle control valve and see if that helps. Also the remote central locking is a bit funny sometimes will unlock other times it opens and then locks again staright away - is this the same as the 166 where it needs the lock motor replacing and is it an easy job?

Dan
 

·
Registered
Joined
·
837 Posts
Discussion Starter #3
Hopefully this will show up:



As you can see the paint is very matt in colour so not 100% sure what to do yet with it. I did check the hose and looks ok but will remove it completely and see if there are any splits in it.

Dan
 

·
Registered
Joined
·
1,084 Posts
I have been on here some time, had a 164 12v cloverleaf, a 166 3.0 sportronic and had a spell away with some other marques and now back in the fold with T reg 2.0 twin spark GTV.

It is a nice little car it is lusso spec, so has the 'ribbed' leather seats etc. Has done 85k with some history with it. I picked up the car very, very cheap as being red it has faded like most do but the previous owner decided to use rattle cans rather than polish it up! :( :cry: So it is a rather matt red currently, hoping i will be able to cut this back and get at the paint but time will tell.

It has a noisey release bearing on the clutch and the usual airbag light is on as well as the idle seems to hunt quite a bit, but will clean the idle control valve and see if that helps. Also the remote central locking is a bit funny sometimes will unlock other times it opens and then locks again staright away - is this the same as the 166 where it needs the lock motor replacing and is it an easy job?

Dan
check both doors and bonnet are closing properly. Is each door actuator pin dropping when you lock............check the multipin connectors are secure and tight on each door to body connections
 

·
Registered
Joined
·
837 Posts
Discussion Starter #5
It's more obvious when you unlock, the drivers one stays down sometimes and the passenger one pops up and goes back down again, as I say does it sometimes not all the times, but thank you for the advice will check that out.

Dan
 

·
Registered
Joined
·
4,980 Posts
Hopefully this will show up:



As you can see the paint is very matt in colour so not 100% sure what to do yet with it. I did check the hose and looks ok but will remove it completely and see if there are any splits in it.

Dan
I like matt red, nice and individual :D
 

·
Registered
Joined
·
6,693 Posts
The doors on my Spider do the same. As did the ones on my 166 from time to time. Good squirt of WD-40 down the door pin holes, usually sorts it for a while.:thumbs:

Nice GTV BTW, loving the colour...:)
 

·
Registered
Joined
·
837 Posts
Discussion Starter #8
The colour is the reason it was so cheap!! I am hoping I can wet sand it back to the faded paint and I might be able to polish that but if all else fails then I will just paint it properly in matt red, at least make it look respectable!
 
1 - 9 of 9 Posts
Top