Alfa Romeo Forum banner

1 - 4 of 4 Posts
D

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Good day all...

Recently picked up a 2006 GT JTDm, I have wanted one for years but always had company cars.....now that's not the case I decided to jump in and must say I am delighted with it!

The previous owner hasn't looked after it well at all, so I have some work on my hands unfortunately...but it drives excellently!

Anyway, I have a few queries that I have picked up over the past few weeks:

1 - The car is warning me that I have a light failure, I have checked and checked again, all bulbs are in working order....could this be something I'm missing?

2 - How easy is centre console swap out? The previous owner has cracked mine - but instead of trying to fix it properly has just drilled two holes and cable tied the break together. Also the cigarette lighter isn't the best, chargers don't sit properly etc due to damage.

3 - Whilst attempting to clean the interior, I pulled up the little rubber mat next to the handbrake and revealed a small electrical connector (two pin plastic about an inch long) - is this standard? What's it for?

That's all I can think of right now...all help appreciated!
 

·
Registered
Joined
·
1,928 Posts
waht lights is it telling you are out , mine says number plate or sidelight etc....there are two numberplate lights are they both working......are both sidelights working.... all u can do if everything is working is to try re seat the bulbs

cant see ceter console been hard to change

its normal for that connector cant remember what it is for but it should be there
 

·
Registered
Joined
·
30,079 Posts
As above, numberplate lights are often missed.

Also, check that they are proper bulbs and not LEDs.
LEDs without a load resistor will bring on the warning light even though they are working.

Remember that the only lights monitored are:
Front sidelights (The H6W ones)
Rear sidelights
Brake lights (not the centre one)
Rear fog
Indicators.

If all are ok then I think it can point to a body-computer issue on the 147/GT.
 
1 - 4 of 4 Posts
Top