Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
After 18 months of troublesome motoring , I traded my 2.4 JTDM in for brand new Giulietta 1750 QV.
I am going to miss the laid back cruising ability and auto box of the 159 , but my patience was up. Hope the QV brings happier motoring.

So far very impressed , it pulls beautifully with almost no lag , smooth ride and feels refined.

Regards

Carl
 

·
Registered
Joined
·
329 Posts
Congrats!...

Was "flirting" with one on the road today for some time, white QV, stunning car, definitely growing on me.
 

·
Registered
Joined
·
1,301 Posts
The giuliettas seem well screwed together, so you should have many miles of troublefree motoring ahead. Big up for sticking with the brand after the 159 gave you troubles, I hope your new G rewards you for it! Oh, pics please...
 

·
Registered
Joined
·
13,815 Posts
Pics please, what are your specs? Im strugling to find one with bi-xenons
 

·
Registered
Joined
·
7,047 Posts
Probably DPF related. And a total lack of knowledgeable dealers.:rolleyes:
 

·
Regional Representative, For South Africa - AO-SA
Joined
·
5,467 Posts
Sorry Carl,m been missing your calls all day..... I am not ignoring you, just perpetually in meetings :(
Best of luck with the new car !

Forgive me , I am not trying to offend, but to answer Guili about what was wrong with the car....
Lance , not much. Carl just did not get the level of dealer service he was expecing on the car..... he ended up fixing some of the minor problems (like rattles) himself, when the dealer apparently "could not find the problem".

As far as I know the car was great mechanically, and it definitely is great cosmetically.... I can personally vouch for that
 

·
Registered
Joined
·
31 Posts
Discussion Starter #9
Thanks Eric.
As Eric has stated, probably not the car itself , but combination of things and dealer inability.

I loved the car , but problems started with various rattles, which dealer could not sort out, managed over many weekends to fix all myself. All were minor things. For laughs the car was at dealer for a week and they said they can find nothing. Managed to trace vibration to wind entering between wheel arch lining ( front) and fender. Some silicone applied neatly quickly resolved the noise.

The real problem started in Dec last year , when in traffic car would cut out , with warning " excessive radiator fluid temperature " , temperature was normal on all times. Went to dealer 4 times, said nothing was wrong with car. Thought it could be the Parrot handfree kit, had kit removed and replaced after which car was fine until last week when all started again.

Bottom line, dealer says not the car, parrot guys say not the unit. Noone can find the fault and I am left with car stalling in traffic every morning. My synopsis is that it is electrical and possibly a earthing problem, this causes the electronics to misread thinking car is overheating and then engine is shut down in "safe mode".

The car is pristine , inside and out , of the 8 Alfa's I have owned in my lifetime this was the only one with issues. Decided to give the brand one last go , with the QV.

Regards

Carl
 

·
Registered
Joined
·
2,758 Posts
The car is pristine , inside and out , of the 8 Alfa's I have owned in my lifetime this was the only one with issues. Decided to give the brand one last go , with the QV.
:thumbs: Great stuff. Hope the QV can deliver the goods, let us know what you think;)
 
1 - 10 of 10 Posts
Top