Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
419 Posts
Discussion Starter #1
Good evening all. Well I've traded in the 147 after 6 and a half years and picked up my Giulietta yesterday. Now I need some advice! Apologies in advance for all the questions but I want to look after it!

Servicing
It's a 1.6 JTDM-2 and has 26k miles on the clock. From what I can see it has a 2 year service period. The car was registered November 2012 and had it's first service Jan 15 at 18,100 miles. The trader changed the oil and filters. Can anyone advise
  1. When should I go for the second service? November? Now? 24Kmiles?
  2. When should I get the water pump and belt changed? 4 years? 5 Years?

Next...

Leaking... maybe...
It could be paranoia from reading threads here as the car has been in a forecourt for over a month but there has been a lot of condensation inside the car and some ice this morning on the inside of the window. The recess for the spare wheel seems damp. I've saw a few threads saying it could be the wiper and to slide silicone grease under the wiper seals. Has anyone had much success with this? Also I've checcked the bungs/grommets/rubber doohickys on the base of the hatch. Middle appears to have a hole and sides seem solid. Should I remove them? poke a hole in them!

Last...
Start/Stop. Is it particularly hard to get all the required criteria for start/stop to function? Eg. engine warm, Climate control off, demister off, Mars in line with Jupiter.

Apologies again for the legnth of this and thanks again for making it to the end of my post!

Cheers, S
 

·
Registered
Joined
·
8,786 Posts
22k or 2 years for the oil change, whihever comes sooner. But I half that in my car. after 22k the oil pressure light will blink at you, I wonder if the trader could reset the oil change counter.

in the 4th yearI'd get belt + waterpump changed: limit is 5 years.

run the car with AC on and the recirculation on, this will get the air in the car drier and drier. Do this until there's no more damp windows in the morning. I only get damp on the outside of the windows....

S/S: you need to be wearing your seatbelt aswell, heater shouldn't be blowing hard and wipers on slow interval. climate can be on, but needs to be in a steady state
 

·
Registered
Joined
·
419 Posts
Discussion Starter #3
Thanks. The drive home there took about an hour. Not sure if the car will be any dryer but my contact lenses are about to crust up. Will take the spare wheel out when I get time to see if I can see water pooling.

Turned everything off for the last minute of the journey but start stop didn't work. ?



Sent from my Sega Mega Drive
 

·
Premium Member
Joined
·
42,865 Posts
If you're not getting a message '' start/stop unavailable'' and a large circular warning symbol in amber showing in the bottom left of the central led display, then the system is ok. It'll just be that all the required parameters for it to operate aren't met :thumbs:
 

·
Registered
Joined
·
419 Posts
Discussion Starter #5
Thanks, It's maybe just too cold up here! Will keep an eye on it. Probably get the belt and pump done in November.

all that's left is the potential foot spa in the boot!
 

·
Registered
Joined
·
419 Posts
Discussion Starter #6
It works! Stopped and started this morning.

Just the possible leak left then hopefully she's perfect ?

Sent from my Sega Mega Drive
 
1 - 6 of 6 Posts
Top