Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1
Hi Guys,

Picked up my Alfa today and have a few little niggles that Im hoping will be easy to resolve.

Firstly, some of the bulbs on the dash have gone. The temp gauge and half the speedo including the little display. Can they be replaced?

Secondly, my fuel gauge is giving me wrong info. I put £20 in fuel and the needle hardly moved. I would have thought £20 would have at least given over quarter of a tank lol. Can the sender unit be cleaned or should I just replace it?

Cheers

Jason
 

·
Registered
Joined
·
276 Posts
Hi Guys,

Picked up my Alfa today and have a few little niggles that Im hoping will be easy to resolve.

Firstly, some of the bulbs on the dash have gone. The temp gauge and half the speedo including the little display. Can they be replaced?

Secondly, my fuel gauge is giving me wrong info. I put £20 in fuel and the needle hardly moved. I would have thought £20 would have at least given over quarter of a tank lol. Can the sender unit be cleaned or should I just replace it?

Cheers

Jason
Would the fuel gauge be connected some way to the faulty lights/dash?

Fuses?
 

·
Registered
Joined
·
9,490 Posts
Speedo bulbs are easy to do - one screw to remove the cowling, then two at the bottom of the gauge and you can fiddle it out, unplugging the electrical connectors - then the bulbs are just a twist fit...

The temp gauge isn't complicated, just very fiddly as you have to remove the radio, and the whole centre console to get at the gauge block (all three are in one unit). There will be a guide to removing the console if you do a search - haven't time to type it all out now:) If you go down this route best to change the bulbs in all three gauges otherwise sod'd law says another will fail shortly after you've done the work.

Fuel gauges are notoriously vague - they register wildly different levels depending on whether the car is parked nose up or down and the degree of any slope - its quite common to start a trip showing 1/4 tank and find it registering 1/2 a few miles later....you just get used to it;)
 
1 - 3 of 3 Posts
Top