Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
726 Posts
Discussion Starter #1
Hi All,

Got a new 3.2 Brera 3 days ago, and I love it, it's easily the best car I have ever owned, the only problem I found with it is that when the Air Con is running there's a loud whining noise. Are these pumps normally noisy, should I get it looked at?

At first it sounded like the same noise I got from an old Audi I had when the gearbox bearings went, but nowhere near as loud.
 

·
Registered
Joined
·
226 Posts
Hi All,

Got a new 3.2 Brera 3 days ago, and I love it, it's easily the best car I have ever owned, the only problem I found with it is that when the Air Con is running there's a loud whining noise. Are these pumps normally noisy, should I get it looked at?

At first it sounded like the same noise I got from an old Audi I had when the gearbox bearings went, but nowhere near as loud.
You don't make it clear if you are hearing this sound from within the cabin while driving, within the cabin while stationary or standing outside while stationary. If it's the last, then there is no problem - situation normal. Either of the first two warrants a check, imho!
 

·
Registered
Joined
·
726 Posts
Discussion Starter #4
It's when driving, the noise goes louder the harder it's revved and stops when the aircon button's turned off. Just wondered if I should expect to hear anything from the compressor, but looks like the answer is no!

Thanks!
 

·
Registered
Joined
·
24 Posts
I had exactly the same problem with by new Brera S. If its the same as mine it sounded a bit like an old fridge ticking over and stopped when the aircon was turned off. Also the aircon never got particularly cold

I have a geek of a friend who identified the problem in no time... the dopes at Alfa hadnt put any coolant in the compressor so it was running on empty.

Booked it back in under warranty and fixed in no time

A classic example of a stupid 'Alfa Niggle'
 

·
Registered
Joined
·
726 Posts
Discussion Starter #6
I was worried about buying an Alfa, though I think most of the reliability problems were either made up or sorted, but the few niggles the car has come with at 9000 miles don't look promising!
 

·
Registered
Joined
·
726 Posts
Discussion Starter #7
I had exactly the same problem with by new Brera S. If its the same as mine it sounded a bit like an old fridge ticking over and stopped when the aircon was turned off. Also the aircon never got particularly cold

I have a geek of a friend who identified the problem in no time... the dopes at Alfa hadnt put any coolant in the compressor so it was running on empty.

Booked it back in under warranty and fixed in no time

A classic example of a stupid 'Alfa Niggle'
Same here, air con recharged and buzz is gone, do you suppose it running low would have damaged the compressor at all?
 
1 - 7 of 7 Posts
Top