Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi Folks,

I have been quite inspired in my short time on this forum as to the amount of people helping each other out.

Without further due,

I recently broke down which was down to the bottom pulley "splitting in 2", This had since been replaced with a new one and a new belt.

However I have been getting a lot of vibrations in my steering when it did not exist before.

Is this potentially a power steering pump on it's way out, or is it perhaps something else?

Many Thanks,
 

·
Registered
Joined
·
303 Posts
Wonder what caused your pulley to crack? Perhaps there'd been a fault in it when new just waiting to fail....

There are many on here who know more about these engines than me, but I have read on here of racks going u/s. Is the problem worse at full lock? I'd also look at wheel alignment, warped disc as well (although that would produce a pulsing through the pedal normally).

I have the same model as well as a couple of classic Alfas. Really like the 159 and the engine seems very robust so far. Hope you enjoy yours.
 

·
Registered
Joined
·
1,178 Posts
Hi Folks,

I have been quite inspired in my short time on this forum as to the amount of people helping each other out.

Without further due,

I recently broke down which was down to the bottom pulley "splitting in 2", This had since been replaced with a new one and a new belt.

However I have been getting a lot of vibrations in my steering when it did not exist before.

Is this potentially a power steering pump on it's way out, or is it perhaps something else?

Many Thanks,
When you say vibrations, do you get these all the time or just when turning the steering? Perhaps when the crank pulley let go it caused some damage to the steering pump or pump pulley.
 
1 - 3 of 3 Posts
Top