Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hi all just got my 1st alfa 147! it's only took 16 years:thumbs:
she's a 147 lusso with 91000 miles on her, was a bit unsure with the high milage and theres not much service history:confused: hope i haven't bin stupied!
 

·
Registered
Joined
·
4,407 Posts
Welcome to AO :)

Saluti, Giordano.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
Hi All thanks for the welcomes! as a newbi cant post more tech qu's but if anyone could help i'v a few probs,....... my 147 2.0ts feels realy light an twitchy on the steering had new front arms (all) fitted front wheel agligment done tyre presurse correct for the 205/55/16 fitted, im thinking of lowering shocks and springs and putting 205/50/16 on think this would help? it realy does roll in the corners, and 2nd when im crusing at 30 ,40 , 50 well any set speed it feels like the engine is hunting even on cruse control it feels very jerky an just not righ?. had the throtel flap cleaned out, still no better. plz any help would be fantastic!!!!
 

·
Registered
Joined
·
1,734 Posts
Welcome and congratulations , my mileage is similar .
The steering is precise and twitchy on the lusso i find , direct .
It should drive like a go cart stuck to the road .
Dunno about cruise control or the 2.0 might just be the power as they horse on .
The folks here are passionate and knowledgeable they'll keep you right .
:thumbs:
 

·
Registered
Joined
·
21 Posts
Discussion Starter #9
Thanks for replies :) its hould be like a go cart. but its not! infact i dont like to push it, it feels like is going to have me in a hedge!
 
1 - 10 of 10 Posts
Top