Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi all,

I have a very annoying problem with my alfa:
Sometimes when i start driving, the ECSF light goes off and the car starts to stutter. I can only make it go away if i re-start the car. at first i thought i was the gas pedal, but replacing it only solved the problem for a month and it happened all over again.

When my mechanic connected his diag computer, it said something about gas pedal sensor 2, so he thought it was the throttle and replaced it.
After driving it for a few days, the problem is back but a new error appears and this is where i need your help. the error is:
Code001; 1226(ff,ff,12,26)
My mechanic doesn't know what the error means and Google didn't help much.

I'm really getting tired from this issue and i would really appreciate any help here..

Thanks
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Hi guys i still need ur help here..
My mechanice changed the gas pedal and the throttle but the problem is still there.
I noticed it's getting worse:
now when i drive i can feel like the engine is not getting enough fuel and it stutters just a bit (in low gears u can really feel it, in 3-5 gear a bit less) and then after a few minutes of driving like that, i get the MCSF light and the car just drives badly.

Got any suggestions? i'm hopeless
Thanks
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
I just reset the ECU using the forum guide, but no luck.
well, at the first few minutes the car drove perfectly but at some point the error reappeared.

I then tried to disconnect the MAF and the MCSF light still comes on but i think the car doesn't stutter like it used to and i don't feel any power lose.. like the light just goes on but everything else is fine.
I want to try it out for a couple of days, is there a problem driving with the MAF disconnected? Can the MAF really cause the car to stutter\loose power (severely) ?

Thanks
 

·
Registered
Joined
·
9,331 Posts
Can the MAF really cause the car to stutter\loose power (severely) ?
Oh yes!

Make sure the replacement is a BOSCH and not a third-party make. It won't last!
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
Ok so new issue.
The MAF seems fine as after a few rounds without him the problem remained.

I went to the mechenic to read the error codes again, and this time it says something about 'Throttle position sensor B\2'
My Mechanic doesn't know what the number 2 means. He thought it's the thorottle body, but we already replaced that.
Any clue here guys ? Can i get this error with bad wiring? (i think there might be some moist around the connectors-although i have no idea where they are)

Thanks
 

·
Banned
Joined
·
9,721 Posts
Good I was hoping you'd come back with that info, the code means the feedback line from the throttle body position sensor is not returning the signal back to the ECU so it is compensating using the crank sensor, MAF and Lambda, because the car continued its antics with the MAF unplugged I would be looking at the multiplug on the back of the inlet manifold and checking the pins are straight in the ecu sockets ontop of the throttle body.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
Ok so just got back from the mechanic again, and have new error codes:

P0220 Accelerator Pedal Position Sensor Signal Improbable
P1221 ???
P1226 ???

I just want to remind u:
- Changed the accelerator pedal to a used one
- Changed the throttle body to a used one
- Tried driving around with the MAF unplugged which made no difference

Any clue ? I'm searching around the forums but still no luck

Thanks
 

·
Registered
Joined
·
9,912 Posts
Ok so just got back from the mechanic again, and have new error codes:

P0220 Accelerator Pedal Position Sensor Signal Improbable
P1221 ???
P1226 ???

I just want to remind u:
- Changed the accelerator pedal to a used one
- Changed the throttle body to a used one
- Tried driving around with the MAF unplugged which made no difference

Any clue ? I'm searching around the forums but still no luck

Thanks
could putting second hand units on giving you new problems:rolleyes:
 
1 - 11 of 11 Posts
Top