Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter #1
Hi,
Just shook hands on a champagne? coloured '96 164 2TS 97K. Fairly tidy for its age, only issue are a faulty passengr side wing mirror (someone bashed it off and while it's back on it's no longer motorised, maybe repairable ?? )
main issue is he sunroof, works but very slow to return when closing. I know you need to see these things to be sure but has anyone any experience of what the problem might be....ie. motor on way out, or runners broken??? seeems to run relatively straight just labouring to get closed. I'd love to have it working for the summer.
Cheers in advance of any answers. Oh and after 10 years since my 145 and 33 before that it's great to have an Alfa again. Bring on the grief ;-}

Oh and I've got two keys, the credit card with the refernce number on, but no master, will I be able to get a replacement key/master with these ??? I know it's unlikely I'd lose both though ....


Oh and some reassurance the appalled looks I've got from the girlfriend will be worth it ?? Anyone want to buy a saab??
 

·
Registered
Joined
·
42,287 Posts
Demon reedler,not sure but think!!! it maybe the same as my much lamented Thema. Me memories failing, but seem to remember having to remove interior light ass. plus interior mirror to access the motor.Talking about 10 yrs ago, but seem to recollect it was the Earth on the motor, cleaned commutator/brush area, sprayed steel bowden/spring cables, got the thing working! Has yours a slot to wind it back manually? Best 'O' Luck, Z.F.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #3
hi zulu thanks for the info. it does have the manualm slot allright, which is comforting as like a "wet paint" sign I had to touch the damn thing the motor took about five minutes and a helping hand to close it back. I'm assuming it's a worn motor as I can't here it running or grinding if it was trying to fight agains a broken track, bracket or something.... anyway Ill try cleaning the contacts anyway...

cheers again...
 

·
Registered
Joined
·
42,287 Posts
dr get the motor out if you can, they are a sturdy setup, ovehauled two on Themas with slow/no run problems. Cleaned, good earths made, good as new. No more probs.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #5
will do thanks again.idn't think it would be overhauled if it had got so slow, however you may save me a trawl through a breakers yard and a few pounds.
 

·
Registered
Joined
·
35 Posts
Welcome to 164land demonreeler.
Appalled looks from girlfriend. Let me reassure you, it will get better when she realises the stunning good looks :cool: (the car I'm talking about), then worse when you get your first electrical fault, or the third possibly :rolleyes: (in case you forgot what it's like with an Alfa).
Hope you enjoy the car, and good luck with sorting the faults!
 
1 - 6 of 6 Posts
Top