Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
hello everyone new to this as i have just bought my first alfa loving the car best i ever had ,ive got a 156 2.0 ts just on 99000 service hist to 76000 i,ve had this for about a month now . THE PROBLEM , starting to judder at low revs ideling when stationrey , but to day the car cut out at the lights tried to start it but just turned over ,(noticed the injector light was on ) anyway getting towed home put the car in 3rd gear and she started ,(strange) at this point i noticed the petrol lightcame on so i filled up at the garage , so driveing home and guess what cut out again , got towed yet again and she started , any help or pointers or advice will be very much appriceated
cheers
fran
 

·
Registered
Joined
·
3,801 Posts
If I were you, I would do an ECU reset. Mine was a bit lumpy at low revs and this sorted it out.

Disconnect the battery for at least 45 mins
Reconnect and start the engine but do not touch the throttle and let the car idle for 15 mins.
Turn the car off and leave for 10 mins.
Start the car and take her for a blast.

There are a million things it could be...... the MAF being the main one, but the ECU reset is a good free place to start.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #3
thanks for that as i only have the red key for my alfa and the push button was broken i always put the key in the door for locking and unlocking if id did the ecu reset would this make a difference , thanks francis
 

·
Registered
Joined
·
421 Posts
Sounds like crank/RPM/TDC sensor. Is the engine hot when it cuts out? And when you get it started, it's cold?

Relatively cheap part (around £25 delivered), which can be bought at the shop here. Fitting is another matter as it's a bit of a pig.

PS welcome to the joys of owning an Alfa........
 

·
Registered
Joined
·
63 Posts
Discussion Starter #5
cheers , just done an ecu reset seems to running fine now hope fully ?
think il join the AA lol
il get a full service ,full cambelt done with reading problems with them snaping dont fancy an engine rebuild if it snap's
 
1 - 6 of 6 Posts
Top