Alfa Romeo Forum banner

1 - 20 of 28 Posts

·
Regional Representative, For South Africa - AO-SA
Joined
·
5,467 Posts
:D First day back at work Cuzz ??? :(:cry::p
 

·
Registered
Joined
·
274 Posts
Discussion Starter #4
It's lying about the fuel consumption as well......

And it is lying about the engine.....
 

·
Regional Representative, For South Africa - AO-SA
Joined
·
5,467 Posts
Thats 'cos its now a 3.2...... :lol:
 

·
Registered
Joined
·
13,815 Posts
3.2 Sportwagon??? WOW!!
 

·
Registered
Joined
·
7,047 Posts
But it was 19.5deg outside so its not all lies.:rolleyes:
Maybe if the tell the onboard computer that it is a 3.2 with 3.2 injectors it will stop lying to you.
Then again it can remind you how good the consumption would have been if you kept the 2.5 in the car.:cheese:
 

·
Registered
Joined
·
7,047 Posts
:cheese:
You do but as you know I have one of the limited GTA 159's that weigh less.:rolleyes:
 

·
Registered
Joined
·
596 Posts
...but is also less aerodynamic....
 

·
Registered
Joined
·
7,047 Posts
Fortunately it’s not hot so the windows can stay closed.:cry:
Your Tumble dryer still fun to drive Jaco?:lol:

Will you be looking at the GT tonight? :cool:

Next Wednesday is club meeting remember. No excuses.
 

·
Registered
Joined
·
3,118 Posts
Think the date is due to leap year, change the year to something like 2006 until march 1st and that should solve the problem. Mine seems to be ok so prob set on the wrong year.
 

·
Registered
Joined
·
7,047 Posts
We also assumed that it is the leap year messing with its brain.
He will have to live with it until Marche only problem is that until then we will have to remind Cuzz what day it is.

You know what old people are like and he turns 30 this year.:cheese:
 
1 - 20 of 28 Posts
Top