Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,450 Posts
Discussion Starter #1
Had a wee search but can't seem to see anything the same.

My car ('53 147 Selespeed) has been off the road (SORN'd) since the middle of October and is going back on the road at end of January. Been keeping it ticking over 1-2 times a week and running it up and down the private road that I live on. Probably been looking after it better just now than I ever do when it's on the road!

Been away for a few days and when I've come back... I tried to start the car and there seems to be some very strange noises coming from the computer/engine.

The central locking is working fine, the dash lights and fans are working, yet, when I try to start the car i get a very fast repetitive clicking noise and some of the lights on the dash flash like the blackpool illuminations. Is it my battery? Starter motor?

Any help/advice would be appreciated.

Thanks :thumbs:

P.S No warnings of VDC failure or anything of that kind
 

·
Registered
Joined
·
8,063 Posts
I'd say definitely the battery.............probably just needs charged

seem to remember something very similar when I had my Selespeed
 

·
Registered
Joined
·
1,450 Posts
Discussion Starter #3
My battery indicator is black and has been for some time. This is what I suspected it would be, but everything apart from the engine is working!

I'll get the voltmeter out and jumpstart it later. This cold weather and time off the road could be the excuse i've been needing to get a new battery.
 

·
Registered
Joined
·
8,063 Posts
Selespeeds hate worn out batteries and can do all kinds of weird things even once the engine is running.

As to the battery, in my V6 if the battery is low then everything works but the starter doesnt turn over at all - was kind of confusing the first time since everything seemed to work ok. Jump started it and it started up straight away, then realised I'd left the interior light on over night :rolleyes:
 

·
Registered
Joined
·
1,450 Posts
Discussion Starter #5
haha that's an interesting insight, thanks Pascs!

Just need to figure out the right battery for my car now!
 

·
Registered
Joined
·
8,063 Posts
At least you can get into your car, when I used to live in Scotland, half the time my Alfa's doors were frozen shut in this freezing weather :lol:
 

·
Registered
Joined
·
1,450 Posts
Discussion Starter #7
lol a wee bit of grease round the seals before the bad stuff hits is always a priority in the Highlands!!
 
1 - 7 of 7 Posts
Top