Alfa Romeo Forum banner

1 - 20 of 33 Posts

·
Registered
Joined
·
7,032 Posts
firstly check the relay ! and before that the battery !!!
 
H

·
Guest
Joined
·
0 Posts
Dont trust the relay position from the guide, there are quite a few reports on here of them being wrong.
If it is the pump it could be just the brushes, particularly if its been doing the same thing intermittently before, do a search on here for pump brushes.
 
H

·
Guest
Joined
·
0 Posts
Is the car definately in neutral?

Did it coast when you lost drive?
 

·
Registered
Joined
·
30,171 Posts
If the system can't get Neutral (or thinks it isn't in Neutral) it will not allow the starter to turn over.

As you have had issues with 4th, search on here for the issue of swarf collecting in the gearbox endplate blocking the selector shaft.
Quite a common problem.

You may have gone beyond that now though!!


Check the main connector to the actuator first though.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #8
right just gone out and had another gander, full batery pumps deff primeing, car sits in flashing nuetral wont sellect anything trys but nothing happens altough after a few attempts pump re-primes is this normal? I pressume it is as has no running engine, dave c might of gone behond this?not sure what you mean mate, also if the car thinks its no in nuetral when it is is there anyway I can reset the ecu? i.e disconect battery over night. going to take day of work 2morro to strip it down
 

·
Registered
Joined
·
275 Posts
Despite it flashing N it sounds like its stuck in 4th m8 and since its stuck in 4th it wont let the starter motor engage.

What DavidC means by its gone further than that is that is its possible that the swarf has built up and totally fubar'd the box. I don't know why I didn't think of the swarf issue when you mentioned it to me, appologies for that.

Pump will re-prime when pressure drops too low, probably not an issue.

Did you get a copy of Alfadiag? Worth checking for error codes. You can also use the manual actuator command to try and force it out of gear.
 

·
Registered
Joined
·
275 Posts
OK so if its definately in N and the Starter won't turn over then perhaps its a duff Selespeed ECU? If its in N then the ECU should let the starter turn over.
 

·
Registered
Joined
·
275 Posts
If the selespeed unit is functional, then probably you could probably get £1200-£1500 if you stipped it but it will take some time to get it back and you'll need somewhere to store the bits.
 

·
Registered
Joined
·
275 Posts
If you can hear the pump whirring and you can hear it trying to engage the gears then you could be looking at a dead box, duff ECU or shot actuators. If the pump was shot I'd expect no whirring and/or the selespeed light to flash. The ECU seems unlikely but I can't understand why its not letting the starter engage, not that it will help to start a car you can't get into gear :(
 

·
Banned
Joined
·
9,721 Posts
its deff in nuetral as we have had to push it for half a mile to get aa to recover it lol.

no need to apoligise mate you where not to know, if it buggered what they worth it I break it? i took this in p/x for a mint condition zs 180 less than 4 weeks ago and now feel sick at the thought that I might be car less
Don't break it, Whereabouts are you? I'll be near Swindon from Dec and this sounds like a good project.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #17
im in nottingham mate Im thinking of banging the car on ebay spares or repair, I dont have the heart to break cars after having to rip my old 620 turbo apart after it was writen off, surely shes worth 500-600 in curent state? I will take the end plate of box 2morro and give it all a good clean and have a look at the actuator and the plugs ect, although the actuator was replaced by previous owner.
 

·
Registered
Joined
·
30,171 Posts
I'm in London, so a bit far for me.
I'm sure there must be someone near you with AlfaDiag.
 
1 - 20 of 33 Posts
Top