Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I need some guidance, I've just bought a 1999 Alfa 156 ts Selespeed and for some reason its just starting to Hunt, if I'm sitting in traffic it hunts just under 2000rpm and then when I pull away there isnt any power but then I get a big kick and the cars off ! ! Does anyone have any idea what I need to do???? as I have been told that either the Thottle body needs changing or the Oxygen sensor or even both ?? thanks
 

·
Premium Member
Joined
·
19,119 Posts
Could be the air mass flow sensor slowly ending its life. Would make it hunt and become slow to pick up. Does it cough back at all?
 

·
Banned
Joined
·
9,721 Posts
Possibly MAF, but first clean the throttle body and reset the ECU, then change the air filter. If that fails then check the coil packs for cracking and arcing damage.
 

·
Registered
Joined
·
102 Posts
i had this problem and it was air box from air flow meter to engine was split on the knuckle(not sure they same as my 156 V6) but i left mine and it got worse.
because i left it to get worse i broke the lamba sensor and the CAT. because the engine was getting to much air it was confussing the lamba sensor and started to spit petrol out of the excaust which done my CAT
my advice is to get it sorted ASAP
 

·
Registered
Joined
·
176 Posts
Air/vacuum leak is a likely cause. Also see gazza82's site as he had a long problem which he traced to a 3 quid valve in the end.
 
1 - 7 of 7 Posts
Top