Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
When setting off and whilst driving at slow speeds my car is very sluggish. By this I mean it struggles to get up to speed but once at higher revs boosts performance and seems fine. I've been told it could be the performance air filter causing it but it seems very excessive. Any idea's?:confused:
 
D

·
Guest
Joined
·
0 Posts
Try unplugging the MAF and take it for a drive see if that improves it.

What kind of filter is it cone or replacement element ?
 

·
Registered
Joined
·
5,621 Posts
the MAF is Mass Air Flow meter, it measures the amount of air being sucked into the engine which then allows the ECU to calculate the correct amount of fuel to be injected into the engine, if the MAF is faulty or has been contaminated with the oils from an after-market Cone air filter then it gives faulty readings causing the ECU to either under/over fuel the engine which results in the poor performance you are probably experiencing, if the MAF is faulty then it will need replacing and it's probably best to source a standard air filter or at least try to find a replacement cone filter that doesn't use oils on it. or that's the way i understand it anyway i'm sure someone will be happy to correct me if i'm wrong ;)

the MAF looks like this http://img.diytrade.com/cdimg/554409/3704174/0/1180171501/Mass_Air_Flow_Sensor_MAF.jpg and is part of the air intake system usually the first bit after the air filter
 
1 - 5 of 5 Posts
Top