Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
213 Posts
Discussion Starter #1 (Edited)
My 84 Bhp 2012 1.3 JTDm was tuned to approx. 102PK/250Nm by Savali (NL). Before the tuning, my average milage was approx. 49mpg when i was really carefull. After tuning it did about 51mpg easy, and if i drove carefully it even went up to 54 and more... nice.

One week after the tuning i got an error when revving it on the highway in 4th gear at about 4000rpm. Engine light went on, limp mode. I had it taken to the dealer and they reset the error, which was a P0238 (boost pressure sensor a circuit high). They inspected the car and couldn't find anything at first sight. After that, the car drove fine again, but my milage is now way off, i can't get it over 43-44mpg no matter how i try.

That was 2 weeks ago, yesterday i got the P0238 error again. I've reset it myself this time using multiecuscan.

What could cause this error, and what could be the relation with the low mpg?
I've read about cleaning the MAP sensor, since this is probably generating the error? Could a clogged up map sensor cause higher fuel consumption?
 

·
Registered
Joined
·
213 Posts
Discussion Starter #3 (Edited)
So you are saying either the sensor transmits faulty readings, or the turbo itself is faulty? e.g. sticky vanes problem?
 

·
Registered
Joined
·
213 Posts
Discussion Starter #4
I've cleaned the map sensor, it was pretty clogged up with soot. Also did a forced DPF regen from multiecuscan, which was exciting, the car was parked in the sun and 25 minutes at 3500 rpm made it feel like an oven :biglaugh: after the regen the mpg was at 1:18.5... (43.5mpg).

After that, i've reset the trip computer and did a 45 min. drive, with an average speed of 120km/h (75mph) and the trip showed an average fuel consumption of 1:23.2km (54.6 mpg)... So for now all looks well again :thumbup:

I'm still gonna do a strong forté diesel turbo cleaner treatment (2 bottles in half a tank of fuel).
 

·
Registered
Joined
·
36 Posts
I had it on mine it will go off by its self it was i going to say waste gate i know it not the correct name but i cant remember what it actuly called it begins with a i had mine cleaned up and work as new after if it is that did it dump everything out the exhaust at the time as to protect engine from damage it dumps it and runs as normal minus turbo
 
1 - 5 of 5 Posts
Top