Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
I have an Alfa 147 selespeed lusso 2ltr 16V, and when i start it up it comes up on the computer motor speed failure and the car wontgo higher than 3000 revs. What does this mean and what do i have to do to fix it?

cheers
Al
 

·
Registered
Joined
·
1,109 Posts
your car is in limp mode. take to somewhere with fiat examiner and get it diagnosed.
Your car will tell you what is wrong.
You are really p i s s i n g in to the wind otherwise.
Get it done a.s.a.p before you wreck it.
 

·
Registered
Joined
·
1,109 Posts
Its probably an engine fault. it could be one of so many things it really is worth getting the car on an examiner.
Its just not worth guessing and changing stuff untill you get it right.
You could end up paying hundreds and find out that it is a relay or something stupid like that.
It will cost you about £30 to get it diagnosed. try a good alfa independent rather than a dealer unless your willing to sell a kidney for the repair.
Try not to panick it could be something really simple but it is best not to use the car in the mean time apart from getting it to a mechanic.

The car wont rev past 3000rpm because it has logged a fault that could harm the engine.
Is the engine management light on on the dash.?
 

·
Registered
Joined
·
78 Posts
Discussion Starter #5
cheers and yeah the engine managment light is on aswell. i have been told that it can only be sorted by the dealer, is this true?
 

·
Vendor
Joined
·
45,294 Posts
Camshaft sensor is often the cause of the 3,000rpm brick wall. If it revs cleanly to 3,000rpm but then won't go any higher then I would definitely suggest camshaft position sensor. Does it idle smooth?

Its not an expensive part to replace but replacing it does involve removal of the cambelt, when did you last get it changed?
 

·
Registered
Joined
·
1,109 Posts
cheers and yeah the engine managment light is on aswell. i have been told that it can only be sorted by the dealer, is this true?
No thats ******.
Any good indi will have fiat/alfa examiner.
If there is no alfa specialist near you try fiat as they use the same computer.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #8
yeah it revs smoothly but when you press the accellerator it is not really responsive, goes to about 2000 revs before the car starts moving.
 

·
Vendor
Joined
·
45,294 Posts
Car doesn't move until you reach 2,000rpm.. And first gear is selected right? Sounds like summat up with the Sele system that is causing that to happen.
 
1 - 9 of 9 Posts
Top