Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I have a 2005 1.9 jtdm 16v 147, it's the facelift model. I was driving it today and the motor control system warning light and message came up. The seems to still be running fine and starts ok. Only thing is maybe the actual mpg maybe a bit less. Anyone know what could the problem be. I am hoping not expensive!
 

·
Registered
Joined
·
287 Posts
I have a 2005 1.9 jtdm 16v 147, it's the facelift model. I was driving it today and the motor control system warning light and message came up. The seems to still be running fine and starts ok. Only thing is maybe the actual mpg maybe a bit less. Anyone know what could the problem be. I am hoping not expensive!
Had this message a few month back.

Only ever had it the once. I posted on the forums at the time and was told a dodgy battery could be the cause. I know my battery was on its way out so replaced it.

HTH
 
L

·
Guest
Joined
·
0 Posts
without reading the error code its like throwing darts blind folded & hoping to hit the bulls eye :rolleyes:
 

·
Registered
Joined
·
6,337 Posts
Like many have said the error codes need to be read to determine the problem.
But battery and a sticking EGR valve are 2 well none issues to bring up the MSCF.
 

·
Registered
Joined
·
70 Posts
My 156 JTDm throws this up on very low fuel but it is the default error. Kinda like a crying baby, you know there is something wrong but what that is....
 
1 - 10 of 10 Posts
Top