Alfa Romeo Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
It's that time of year the MOT is due tomorrow, hoping it will pass without too much work. Limit is £250 or it's off to the scrap yard....

:cry:
 

·
Registered
Joined
·
2,429 Posts
Nice looking car from here and that's a bulletproof engine isn't it?

Would be a shame to see it scrapped. I'm sure someone on 155.org would be interested.
 

·
Registered
Joined
·
278 Posts
you will make a lot more in parts to other owners than scrapping it - as also mentioned, will help keep other 155s alive!
 

·
Registered
Joined
·
23 Posts
The only thing you should scrap it on is rust.

8 valvers are worth the effort to keep going, the engine's good for over 200k miles.
I've heard of one that did 400k!
 

·
Registered
Joined
·
80 Posts
Discussion Starter #9
Result

ABS light does not work.....indicating ABS fault?

Rear Brake pipes corrosive

Lamps too low/couple not working

Front Tyre

Handbrake inbalance

corroded front struts mounting

Movement in Rear brake pin/bearings

Failed emissions

Good news.

Anyone know more about the ABS?
 

·
Registered
Joined
·
2,429 Posts
Nice one.

I've been told I need new ABS sensors to pass the test over here. Maybe just replace the sensors?
 

·
Registered
Joined
·
80 Posts
Discussion Starter #11
Nice one.

I've been told I need new ABS sensors to pass the test over here. Maybe just replace the sensors?
Thanks I tell the guys at the garage.

Had the car 2 years with no problems and done about 12k, tyres, brakes, oil and filters keeps it going. v:thumbs:
 

·
Registered
Joined
·
5,699 Posts
they are located on the hubs towards the rear, just below the bottom bolt to the upright you'll see a wire going to them

Good luck getting them off !
 

·
Registered
Joined
·
30 Posts
Although this is risky - how about taking the abs warning light bulb out?

My 8v widey seems to have abs pumps etc, but the abs has NEVER worked in my ownership - front wheels will lock if I brake hard enough.

Someone has, I suspect, removed the warning light bulb.

Never been an issue at MOT time
 

·
Registered
Joined
·
4,191 Posts
all the requirement states is that the warning bulb is not illuminated - there is no requirement for the ABS to actually work that i'm aware of..
 

·
Registered
Joined
·
1,266 Posts
Had an ABS light come on a few years ago and spent a fortune getting a new sensor fitted and then hours of labour by the confused mechanic cos the ABS light wouldn't go out. Turned out to be a frayed wire in the bulk head sending a false signal. He did claim of course that the sensor did still need replacing anyway just to avoid removing it and giving me a refund i think - but worth a second look incase thats your problem??
 

·
Registered
Joined
·
80 Posts
Discussion Starter #17
ABS Problem

ABS light now working when the ignition is switched on, goes out when car starts then comes on and stays on when brakes are applied????
Any ideas?:confused:
 
1 - 18 of 18 Posts
Top