Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello

A week ago first started this problem. I made a stop without turning off the engine and it showed me this message. From that time the steering wheel was too hard to steer. Turned off and on the engine and everything was fine. Until the next time it appeared again the problem. Have you any idea where is the problem?

Thank you in advance
 

·
Registered
Joined
·
636 Posts
It's the steering column, a known problem. You'll need a new steering column if under warranty, or yours rebuilt if it's not.
 

·
Registered
Joined
·
29 Posts
Hi, mine has same faults, disconnected battery for 15mins and reconnected and all have reset for now :thumbup:


but out of interest where can you get it repaired for £150 (not including removal/refiting) and how much does this cost on top of the £150?
 

·
Registered
Joined
·
96 Posts
I paid £395 this week to have my steering column removed, sent off for renovation, refitted then checked and road tested. Garage (FAST Autocare, nr Middlesbrough) had the car for 4 days.
 

·
Registered
Joined
·
636 Posts
Hi, mine has same faults, disconnected battery for 15mins and reconnected and all have reset for now :thumbup:


but out of interest where can you get it repaired for £150 (not including removal/refiting) and how much does this cost on top of the £150?
ALFA ROMEO MITO 1.3 - 1.6 POWER STEERING (EPS - ELECTRIC POWER STEERING) - Part No: 50516920 / 50508600

£150 + vat so £180.

Removal and refitting are about 45 mins each, so whatever your garage charge for that, plus shipping.

Much better than the £1300 column replacement it was for the early out of warranty failures!
 
1 - 6 of 6 Posts
Top