Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I bought a 6 month old Mito Quadrifoglio Verde Cloverleaf 170 bhp with TCT 15 plate in Sept. It has repeatedly stalled since then (approx 3-8 times per month) mid manouevre just after starting, both in first and reverse. I'd never driven an automatic before so thought at first it must be me. But then it periodically wouldn't accelerate when pulling away i.e. my foot is increasingly depressed on the accelerator but no increase in speed until a sudden overrevving and increase in speed. When I took it for its first service the dealer confirmed there was a problem with the software which Alfa were aware of but had not yet worked out how to fix. That was 2 months ago and still got no solution.

Periodically the revs will go up to 5000 rpm without changing gear (at which point I change up manually) - is this normal?

Just wondering whether anybody else had this problem?

The dealer had suggested that I could leave the car at the dealer and drive a hire car until problem was fixed but was reluctant as no guarantee what hire car I would get, was really enjoying my Alfa and dealer had no idea how long would take to fix i.e. could be months. After stalling mid reverse in the middle of the road today whilst a bus bore down on me now thinking that its not safe to drive and will have to request a hire car.
 

·
Registered
Joined
·
1,546 Posts
Fiat/Alfa have had some problems reported with some engines during 2014 & 2015 around the time when they were making them Euro 6 compliant, most notably the 1.2 engine fitted to the Fiat 500 and Panda but there has been some reports of hesitation & stalling on MultiAir engines such as that fitted to the MiTo QV too.

It's probably just some poor software which needs an update - that appears to have worked wonders on the 1.2 engines. However, very often, getting a Fiat/Alfa main dealer to admit there's a problem is like pulling teeth, so if your dealer has offered to take your car until they've fixed it I'd bite their arm off!

Just say you're concerned about the courtesy car & that you don't want to end up with a Fiat 500 1.2 for however long. The dealer sounds pretty reasonable so I'd hope they'd listen, but in any case it has to be a better option than a car which you'll end up not feeling safe driving.
 

·
Registered
Joined
·
4,932 Posts
My Punto Evo used to do this and that was 2010. 6 years on and Fiat group still haven't fixed this??
 

·
Registered
Joined
·
659 Posts
My Mito has done this too and it was bought new in Feb/March. We received a courtesy check letter from the dealer yesterday so will take it back for them to check out and hopefully pop it on the list for when the software update is completed. We shall see. I did originally put it down to the cold weather as the TCT was a bit juddery in the cold too but once the car warmed up it was perfect. I'll keep an eye on this and if I get any different news from the dealer I'll stick it on here.
 

·
Registered
Joined
·
172 Posts
My Mito has done this too and it was bought new in Feb/March. We received a courtesy check letter from the dealer yesterday so will take it back for them to check out and hopefully pop it on the list for when the software update is completed. We shall see. I did originally put it down to the cold weather as the TCT was a bit juddery in the cold too but once the car warmed up it was perfect. I'll keep an eye on this and if I get any different news from the dealer I'll stick it on here.
Was the letter to check for this particular issue?

They'll need to open a case with Alfa Technical when you take it in, even if they can't replicate the issue (if its warmer than about 7C outside).
 

·
Registered
Joined
·
659 Posts
No, the letter was for a general, courtesy check over but it would prove an ideal opportunity to mention the issue. Funny you should say about 7c as it hadn't happened for a few days but it did today and in my neck of the woods it was 6c!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #11
Thanks for this info. It is still doing it even though it is warmer here, but I'll keep an eye on the temperature to check whether it is still doing it when it's over 7c. Am currently waiting for the garage service manager to ring me back as have asked for a courtesy car.
 
1 - 11 of 11 Posts
Top