Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello! I own a 2012 Alfa Romeo Mito 1.4 tb multiair and I am confronting with a problem popular on the Mito.The problem is with the steering corrector. People with the same problem, can you tell me if the car pulled in one direction? Or if the problems are related to each other?I've tried solving the issue with the car pulling to one way, but I couldn't get it sorted out. Mechanics told me that the car mechanisms are in good condition, but it might be a electrical problem. I had multiple aligments of the wheels, multiple aligments of the steering wheel and car tyres moved from one side to the other. I've tried anything and nothing worked for me. The workers at the local alfa dealer try to convince me that there's nothing wrong with my car and that the steering corrector cannot be remediated. Now I'm asking you, is there anything else I can try to fix my car? What needs replacing? It was replaced on the warranty ?Thanks in advance.
 

·
Registered
Joined
·
3 Posts
I have the same issue. But it seems to come up when its super hot and when I've parked the Alfa with the wheels turned. I think on 2 or 3 occassions its pulled me to a side. However the vehicle is booked in for the very problem on Tuesday.
 

·
Registered
Joined
·
48 Posts
Pulling one side issue is not related with the problematic sensor. Go to a service to check your geometry. Is it pulling only on torque , or even if you are not accelerating ?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
It doesn't matter if it's in neutral or in gear. At around 60mph if you don't hold the steering wheel i'm going in the nearest ditch in 2 seconds. :headache:
 

·
Registered
Joined
·
48 Posts
Is your wheel turning or just the car is going one way ? I had problems with the sensor but with no suck behaviour . If you want to change the sensor , i changed mine at a mechanic in Constanta a few months ago.
 

·
Registered
Joined
·
1 Posts
Hello! I own a 2012 Alfa Romeo Mito 1.4 tb multiair and I am confronting with a problem popular on the Mito.The problem is with the steering corrector. People with the same problem, can you tell me if the car pulled in one direction? Or if the problems are related to each other?I've tried solving the issue with the car pulling to one way, but I couldn't get it sorted out. Mechanics told me that the car mechanisms are in good condition, but it might be a electrical problem. I had multiple aligments of the wheels, multiple aligments of the steering wheel and car tyres moved from one side to the other. I've tried anything and nothing worked for me. The workers at the local alfa dealer try to convince me that there's nothing wrong with my car and that the steering corrector cannot be remediated. Now I'm asking you, is there anything else I can try to fix my car? What needs replacing? It was replaced on the warranty ?Thanks in advance.
Did you solve the problem and how? I face exactly the same issue.
Thank you.

Στάλθηκε από το LG-V500 μου χρησιμοποιώντας Tapatalk
 

·
Registered
Joined
·
6 Posts
Did you solve the problem and how? I face exactly the same issue.
Thank you.

Στάλθηκε από το LG-V500 μου χρησιμοποιώντας Tapatalk

Any updates on the problem? Did anyone solved it? Two of my friends that have a mito and my mito ,face the same problem as you guys. Everything looks mechanically perfect, 5 times I had wheel allignment to 3 different workshops and everthing is correct, changed tyre position etc etc but the cars still pull to the right.

I would appreciate your help if you found the problem finally.
 
1 - 7 of 7 Posts
Top