Alfa Romeo Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #1
People just wanted to let you know about this issue that a lot of Mito owners are having.

The issue seems to arrive from no sealant being applied at the factory level when assembling the car.

Have a read and if you own a Mito like me get in contact with Alfa Romeo Customer Service in Milan 1800 342800, and contact your dealership and get the issue resolved with sealant.

http://www.alfaowner.com/Forum/alfa-mito/345293-check-your-sills.html#post4900620


And photo graphical evidence of the issue in hand, BELOW...

http://www.alfaowner.com/Forum/alfa-mito/285005-water-leaking-from-sill-gromets.html



Mine is being looked at at the guys in Dublin, great bunch up there very helpful indeed.

Let you know the outcome.

:rant:
 

·
Administrator
Joined
·
87,326 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #7
Wow that is mad to see glad you caught your's though.
Cheers Damien, me too.... Was saying to David how the Alfa forums are priceless when it comes to these things.

A big shout out to DUCJASON and leemids for pointing out the issue.
 

·
Administrator
Joined
·
87,326 Posts
Yeah your right David, these forums are priceless when it comes to these kind of issues.

AO is really one of if not the best sources of Alfa related info online, especially the Tech Lounges :thumbs:



So how are you getting on with the Mito ?
 
D

·
Guest
Joined
·
0 Posts
Cheers Damien, me too.... Was saying to David how the Alfa forums are priceless when it comes to these things.

A big shout out to DUCJASON and leemids for pointing out the issue.
To be honest you cannot beat here for info it is literally a mine of info majority of it being true and good which is hard to find.
 

·
Registered
Joined
·
89 Posts
Discussion Starter #11
AO is really one of if not the best sources of Alfa related info online, especially the Tech Lounges :thumbs:



So how are you getting on with the Mito ?
Fantastic David, my first ever Alfa and the Mito QV is just incredible, In normal mode she's very fast and subtle and in DYNAMIC she's extremely fast and a FECKING beast.Its just incredible the difference in power...
Have you not had the pleasure to drive one yet or see one in the flesh....
 

·
Administrator
Joined
·
87,326 Posts
I haven't driven a Mito but I drove the Giulietta with the same MA 170 Bhp engine as your Mito as while back, as you say it's a fantastic engine especially in D mode :D
 
P

·
Guest
Joined
·
0 Posts
Stone me, an Alfa with rust issues:)

To be fair though, one poster in those threads mentions corrosion problems with modern mercs and mazda's.

Truth be known car makers could probably make a car that would last forever at this stage, but then they wouldnt sell any new ones.

Glad your mito hasnt rusted yet!
 

·
Registered
Joined
·
89 Posts
Discussion Starter #14
Stone me, an Alfa with rust issues:)

To be fair though, one poster in those threads mentions corrosion problems with modern mercs and mazda's.

Truth be known car makers could probably make a car that would last forever at this stage, but then they wouldnt sell any new ones.

Glad your mito hasnt rusted yet!
Cheers, should get it sorted next week....
 
1 - 14 of 14 Posts
Top