Alfa Romeo Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Last days in greece we have the lowest temperatures of last 20 years(-12C) for a week
Today my headlight sprayers popped out(see photo)
They dont work from the beggining i didnt know that car has something like this
Try to push back smooth but with no result
Any opinions?
 

Attachments

·
Registered
Joined
·
344 Posts
I vaguely recall that on cars where headlight sprayers extend it's the hydraulic pressure of the pumped washer fluid that pushes them out - so maybe the washer fluid in the pipes/mechanism has frozen and that's what's pushed them out and stuck them out?
 

·
Registered
Joined
·
9,305 Posts
Let's hope so .. but if you're not used to low temps have you got enough anti-freezing washer fluid? In the UK we just mix ours as a higher percentage of fluid to water ...
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
Let's hope so .. but if you're not used to low temps have you got enough anti-freezing washer fluid? In the UK we just mix ours as a higher percentage of fluid to water ...
it was only distilled water
Lets hope that it is not damaged onloy forzen and from now on anti freezing water
 

·
Registered
Joined
·
9,305 Posts
WASHER fluid with Anti-freezing properties .. don't use normal anti-freeze or you won't have any paint!

As many parts are plastic, you might not get away without any damage ..
 

·
Registered
Joined
·
20 Posts
Discussion Starter #7
Weather now is hot
Everything is melted
Spayers do not go back to initial position
They work ok fluid is coming out ok spayers are coming out ok the do not return 100% to initial place
My local technician opened but couldnt understand what is wrong and tolc me that costs 100€ each euros to change
I asked him to cancel them cause i do not need them he told me that is not possible and also if he cancels again the do not return to initial position
They seem to be overpressured i cannto undersatnd exactly what is damaged
I am thinking to push them back and put glue:)))
But i will have problem if i forget and use my washers eith open lights because the fluid will go inside the engine space
 

·
Registered
Joined
·
9,305 Posts
Ι suspect that the pistons of spaying system are jammed but i cannot find instructions how to fix them
You probably can't ... they are usually sealed units that you have to swap out. I bet if you manage to open one, you will never get it to seal again :(
 

·
Registered
Joined
·
9,305 Posts
Don't know how they work on a MiTo .. ours doesn't have them. on the 156 there were two pumps in the water reservoir so I disconnected the headlamp pump and blocked off the hose as the spray heads leaked.

Have a look on eper for the parts and see what the water reservoir looks like. You might find a Fiat Punto Grande has the same setup although the head lamp jets are probably different (shape of bumper) ..
 

·
Registered
Joined
·
9,305 Posts
Pump will be in the screen washer bottle surely.

Do you have HID headlamps? If you do you have to fix the sprinkles as you must have a washer system with HID lights in the EU.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #15 (Edited)
Solution found
We removed head nozzle
We cut about 1 cm from head nozzle
We cut about 1 cm from the part that is popping out
We connected two parts and now the total length is 2 cm less and it fits correct
Also it is still working and there is no leak
For some reason the system did not pull back for the last 2 cm so we cut 2 cm in total

I am now thinking to remove fuse F09 and to glue the covers for perfect attachment , in greece they do not check for headlight washing system
I just has to be sure that F09 doesnt effect anywhere else the operation of the car
I removed the fuse for 5 minutes no fault message and also everything seemed to work fine but i have to test it for some days

The only problem is that whenever you have to remove the bumper you have to reattache the covers
 

Attachments

1 - 15 of 15 Posts
Top