Alfa Romeo Forum banner

1 - 5 of 5 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Hi all,

I have aproblem that I've been trying to diagnose for some time now without success.

I have a number of small misfires between 2800 and 3000rpm. They fell like very samll shudders as the revs drop or rise, if I am feeling especially accurate, I may just be able to hold the throttle on one.

I've been through the usual, substituted the coils one by one, new leads, new plugs (needed them anyway) no oil in the plug wells. I've also cleaned the airflow meter (hot wire type) and the throttle body, and there are no obvious vacuum leaks. I've had it on an Alfa examiner and nothing untoward shows up and the emissions I'm told (I didn't observe this) are fine.

Anybody got any ideas>

Simon
 

·
Registered
Joined
·
550 Posts
HI SIMON:
PLEASE, WHAT IS THE CORRECT WAY TO CLEAN THE AIRFLOW METER ?
REGARDS AND GOOD LUCK WITH YOUR PROBLEM
JORGE frown
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #3
examiner wont find faulty plugs or leads or if the fuel filter is getting old check these out first.
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #4
clean your airflow meter very very carefully spray some carb cleaner on a cloth and wipe out all the sludge.
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #5
just letting you know your knot alone my misfire is around 1400 1800 revs and a few others seem to have same prob on the same road of hope as you as you clean each component thinking it might cure it (done my throttle body last week) and yet still no answers even put old spark plugs in today as could not remember if fault was there before i changed them,cant help but feel its electrical but if i find anything i will post results
 
1 - 5 of 5 Posts
Top