Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
830 Posts
Discussion Starter #1
For the last couple of years I've had periodic problems with the menu button on the indicator stalk of my ten year old Brera. I would imagine this will become quite common place now many more 159 derivatives are reaching that age.

The first couple of times I cured the problem by applying copious amounts of contact cleaner but last week this did not do the trick.

The symptoms on my car were not just non operation of the button but also a flashing of different screens on the panel between the two main dials, a very annoying and distracting situation.

I started to think of a replacement set of stalks costing in excess of £400, all the used ones on ebay are for 159s and not only are they different, there's no guarantee they are any good.

Thought I'd have a quick look at the internal workings of the menu button and found that the stalk itself prizes apart quite readily. Inside, there is little more than a small circuit board with very little to go wrong on it, a rotary switch for the lights and three micro switches for the menu.

It seemed that the centre one of these three had seized up, probably caused by the contact cleaner drying the switch out, Fortunately, a squirt of TF3 lubricating spray and a little manipulation freed up the switch and now everything is tickety- boo.

What was obvious is that this circuit board and micro switches would be a fraction of the cost of a set of column switched and would be quite straightforward to solder into place, if they were available and there must be a bin full of them somewhere. :irked:
 

·
Registered
Joined
·
151 Posts
For the last couple of years I've had periodic problems with the menu button on the indicator stalk of my ten year old Brera. I would imagine this will become quite common place now many more 159 derivatives are reaching that age.

The first couple of times I cured the problem by applying copious amounts of contact cleaner but last week this did not do the trick.

The symptoms on my car were not just non operation of the button but also a flashing of different screens on the panel between the two main dials, a very annoying and distracting situation.

I started to think of a replacement set of stalks costing in excess of £400, all the used ones on ebay are for 159s and not only are they different, there's no guarantee they are any good.

Thought I'd have a quick look at the internal workings of the menu button and found that the stalk itself prizes apart quite readily. Inside, there is little more than a small circuit board with very little to go wrong on it, a rotary switch for the lights and three micro switches for the menu.

It seemed that the centre one of these three had seized up, probably caused by the contact cleaner drying the switch out, Fortunately, a squirt of TF3 lubricating spray and a little manipulation freed up the switch and now everything is tickety- boo.

What was obvious is that this circuit board and micro switches would be a fraction of the cost of a set of column switched and would be quite straightforward to solder into place, if they were available and there must be a bin full of them somewhere. :irked:
When you say it prizes apart easily, does that mean in situ or did you dismantle the whole assembly, steering wheel off etc?
Mine stopped working last month, but only after I was [email protected] around with the menu and made the foolish decision to bypass the boot push button. So now I can't get into the menu or set the clock after the BST clock change. DOH.
 

·
Registered
Joined
·
830 Posts
Discussion Starter #4
Did mine in situ, complete pain to take whole unit (all three stalks connected) off.
Thin, wide bladed screwdriver or similar along joint line and gently ease apart, sufficiently to pop the menu button out and prize off the little silver rivet holding the end button on.

There's not much to see, just three micro switches in the form of push buttons. It is the centre one of these that keeps seizing on mine.

I cleaned it, lubricated it with electrical lubricant (GT85 or similar). Gently manipulated it to make sure there was movement present and to check if it worked.

If you are lucky, all should be ok now for a couple of years, if not, that little micro switch costing less than £1 might mean a whole new unit is needed.

If this was Wheeler Dealers, Mike Brewer would probably now of a man in a workshop who could replace the micro switches for £20.
 

·
Registered
Joined
·
151 Posts
Did mine in situ, complete pain to take whole unit (all three stalks connected) off.
Thin, wide bladed screwdriver or similar along joint line and gently ease apart, sufficiently to pop the menu button out and prize off the little silver rivet holding the end button on.

There's not much to see, just three micro switches in the form of push buttons. It is the centre one of these that keeps seizing on mine.

I cleaned it, lubricated it with electrical lubricant (GT85 or similar). Gently manipulated it to make sure there was movement present and to check if it worked.

If you are lucky, all should be ok now for a couple of years, if not, that little micro switch costing less than £1 might mean a whole new unit is needed.

If this was Wheeler Dealers, Mike Brewer would probably now of a man in a workshop who could replace the micro switches for £20.
Thanks for that. I did as you said, flushed with Servisol switch cleaner but found the "up" micro-switch to be collapsed (no spring to the micro-switch). I'm sure a replacement could be found but the whole assembly would have to come off to get into the circuit board for soldering and I don't fancy tampering with the airbag in the steering wheel.

I suppose if I get a whole new stalk assembly I'll have to bite the bullet?

Thanks again
 

·
Registered
Joined
·
830 Posts
Discussion Starter #6
That is exactly what the centre button was like on mine only this caused the screen to keep rotating. These micro switches have a very weak spring and so seize quite readily. A good prod, poke and pull worked for me. :biglaugh:

The circuit board you mention clips out very easily, and if only these were available, could be replaced in minutes.
 

·
Banned
Joined
·
3,110 Posts
I would also open assembly first before buy the new one.
Sometimes contact cleaner + hand brushing of plate ( or board not sure how you call it ) is OK. Depends case inside.
Good luck.
 

Attachments

1 - 7 of 7 Posts
Top