Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Gents....i seem to be having a few issues with an auxillary fuse on my 1998 Phase 1 GTV.

The fuse in question is a 30A with a red/white and red cable going to it. (Photography attached) i noticed the fuse had melted previously so i cut out the damaged wiring and fuse holder and replaced them but today i noticed the replacement has also melted.

Any help will be greatly received.

Thanks
 

Attachments

·
Registered
Joined
·
200 Posts
If you can, check the resistance across the terminals where the cable is crimped (with the circuit off) with the fuse in. As it's on a high current circuit any increase in resistance will cause a large amount of power to be dissipated at the point of high resistance when the current flows. This power is dissipated as heat and causes the fuse to melt.

Any combination of corrosion on the wires, on the fuse terminals, or poor crimping could cause this increase in resistance.

Sent from my motorola one using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Thanks for your reply Theozaurus. I doubt whether the issue is resistance caused by the terminations as the original cable had also melted away. I think its resistance caused by the load. I assume what ever this fuse supplies is drawing an excess load hence the resistance / melting. I need to know what the load is, what this fuse is for
 

·
Registered
Joined
·
2,181 Posts
Is this the fuse to the rear demister?

Sent from my SM-G950F using Tapatalk
 

·
Registered
Joined
·
200 Posts
A higher resistance caused by the load won't melt your fuse housing. The higher the resistance of the overall circuit the lower the current draw. It won't be because your resistance of the load is too low either (a short) as your fuse will just pop.

Your fuse isn't blowing, it's melting because power is being dissipated through it. These high power circuits (like the demister) are notorious for melting connectors when the resistance of the connector increases.

It happens because the resistance of the load is so low, that a small increase in a connector makes it act as a potential divider. You can see for yourself easily by checking the voltage drop over the fuse. It should be next to nothing, but in your case it will be significant.

Sent from my motorola one using Tapatalk
 
1 - 5 of 5 Posts
Top