Alfa Romeo Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
351 Posts
Discussion Starter #1
Drove to work as normal today car was running sweet (GT V6), in fact I was thinking I prefer driving it more than my V8 XKR. This soon came back to haunt me as the dreaded MCSF flashed up and kept flashing, then the engine started running really lumpy, misfiring and sounding terrible with not much power. Gutted!
The car is now in Optima Wootton Bassett, the plug in said cylinder 4 misfire. Hoping it's just a failed coil pack on number 4 but the guys at Optima are maxed out and probably won't get round to it till Friday.
Annoying as I now have to rock up to my speed awareness course tomorrow in my XKR with everyone judging. Ha ha
 

·
Registered
Joined
·
337 Posts
I ask because I get mscf whenever I go over 4000rpm and in flashes up about 10 times in a row. Misfire in multi cylinders.
I'm yet to find an answer so I'd be interested in your result if it has similar symptoms.
 

·
Registered
Joined
·
1,374 Posts
You both need to get compression and leak down tests. I had misfire on front bank, turns out head gasket.
 

·
Registered
Joined
·
351 Posts
Discussion Starter #7
Yeah, I hope it's not as severe as that but cheers for the heads up, the guys at Optima did say we may be lucky, we may not.
 

·
Registered
Joined
·
1,374 Posts
Yeah, I hope it's not as severe as that but cheers for the heads up, the guys at Optima did say we may be lucky, we may not.
Good luck, I hope you don't have to go through what I'm going through. Only bought mine dec!
 

·
Registered
Joined
·
351 Posts
Discussion Starter #9
What have you gone through?! I haven't heard from them yet so will pop in tomorrow morning as they are only a ten min walk from me
 

·
Registered
Joined
·
1,374 Posts
What have you gone through?! I haven't heard from them yet so will pop in tomorrow morning as they are only a ten min walk from me
Spent over 6k now looking to spend 4-5k on top for rebuild, clutch quaife, cam belt kit, radiator, intake hose the list goes on...

Edit- don't want to scare you, could be coil packs etc
 

·
Registered
Joined
·
1,388 Posts
How much!!!

I've had my GT 3.2 for nearly three years and done 25k during that time, and it's not cost me too much to run at all. The only major work has been cambelt and water pump, plus a radiator. I've a few other things such as split front upper strut mount, leaks from around the thermostat housing (failed 'O' rings) and I think the inner track rod joints are going at the mo. None of this is particularly expensive, especially if you can do some of the work yourself.

I would get the code read and look at coil packs/plugs before worrying about engine problems. The V6 is a pretty reliable engine if looked after.....

Fingers crossed.
 

·
Registered
Joined
·
351 Posts
Discussion Starter #13
How much!!!

I've had my GT 3.2 for nearly three years and done 25k during that time, and it's not cost me too much to run at all. The only major work has been cambelt and water pump, plus a radiator. I've a few other things such as split front upper strut mount, leaks from around the thermostat housing (failed 'O' rings) and I think the inner track rod joints are going at the mo. None of this is particularly expensive, especially if you can do some of the work yourself.

I would get the code read and look at coil packs/plugs before worrying about engine problems. The V6 is a pretty reliable engine if looked after.....

Fingers crossed.
Spoke to garage on Sat they are pretty confident it's plugs or coil pack but gonna strip it to look properly tomorrow. I hope it is, I can't wait to get her back
 

·
Registered
Joined
·
351 Posts
Discussion Starter #14
Got the car back today, all fixed and running sweet. I got lucky it was just a coil pack. I'm a happy man again :)
 

·
Registered
Joined
·
1,388 Posts
Good news, glad it was just a coil pack. It's easy to get paranoid about major issues and potential big bills (been there, done that). Shows you always need to check the basics before worrying about major problems like compression/head gasket issues!!
 
1 - 15 of 15 Posts
Top