Alfa Romeo Forum banner

1 - 20 of 39 Posts
M

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Seeing as FiatECUScan doesn't read most of the Ph1 airbag ECU's, I set myself the task of getting my airbag light out without...

A) Using tape over the LED (which is what I have just now), or

B) Going to Alfa and paying out money for the light to come back on again the next time someone farts in a front seat.

Hopefully my fix will work but the thing I bought won't be here for a few days.

Will keep you all posted.....if it works that is !!!

If it doesn't work I have only lost a fiver !!
 

·
Registered
Joined
·
13,685 Posts
Keep us posted. My spider has no complaints about airbags but my GT does :lol:
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Well this won't work on the GT, I know that for sure !!

Get FES and that will be able to clear the light on the GT :)
 

·
Registered
Joined
·
13,685 Posts
I know, the problem is with the passenger seat sensor. I need to take a look at weekend.
 

·
Registered
Joined
·
236 Posts
Hey guys, the airbag light in the MG's is also a pest over the years. There is a very simple fix that you can do that I'm not sure will work on the Alfa's but its worth a go as I'm sure I saw a plug under the seat the other day. Can you not just locate the plug under the seat, disconnect, WD40 and put back together again. this fix in a MG will turn the light off again for a good year if not longer. Problem is caused by sticking sensors in dirty places :eek:
 

·
Registered
Joined
·
8,916 Posts
The plug under the seat is a known issue for Alfa's full stop. The best way to get around it is to permanently join the cables, the plug can break the connection, especially when the seat is moved. The problem is, without diagnostics, the light may be being put on for another reason. The connector under the seat is favourite though.
 

·
Registered
Joined
·
1,843 Posts
A kind previous owner has removed the bulb on mine... Might have to come up with something clever like a timer if the MOT man notices.
 

·
Registered
Joined
·
7,768 Posts
If you buy FiatECUscan you can solve this problem though, its just the free version that doesn't offer the facility. .....I believe!?
 

·
Registered
Joined
·
30,081 Posts
...Can you not just locate the plug under the seat, disconnect, WD40 and put back together again. this fix in a MG will turn the light off again for a good year if not longer. Problem is caused by sticking sensors in dirty places :eek:
Using a proper contact cleaner lubricant (ie Electrolube EML) would be far better than WD40.

WD40 is NEVER the best product to use, it just has a good marketing dept...
 

·
Registered
Joined
·
236 Posts
Using a proper contact cleaner lubricant (ie Electrolube EML) would be far better than WD40.

WD40 is NEVER the best product to use, it just has a good marketing dept...
Any form of contact spray is good spray when something doesnt work :thumbs:
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #13
........and sorting the contact at the seats or any other problem doesn't put the light out. You need to clear the code with FES or some other program or go to the dealer.
 

·
Registered
Joined
·
236 Posts
and sorting the contact at the seats or any other problem doesn't put the light out. You need to clear the code with FES or some other program or go to the dealer.
shame, such an easy fix on the MG this :( but I guess it wouldnt be an Alfa any other way would it :).
 

·
Registered
Joined
·
68 Posts
I know a number of MG owners (I'm one but haven't done this) have removed the connectors altogether and soldered the wires together. PITA if you need yo whip the seats out, but you pays your money...

On my old MG ZT-T, I could make it go out by tucking the connector under the seat spring. Go figure... but it got it through its MOTs
 

·
Super Moderator
916 Spider P1 Lusso
Joined
·
9,446 Posts
I like the way you try it out on here first and then (hopefully) post the solution on nineonesix.eu ;)
 

·
Registered
Joined
·
30,081 Posts
........and sorting the contact at the seats or any other problem doesn't put the light out. You need to clear the code with FES or some other program or go to the dealer.
That is correct, you still need the ECU reset.

as for just blanking the light out, that bodge won't get you though an MOT next year...
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #18
I want to know how they know the car has an airbag ECU ?

The 155 has a drivers airbag, but no ECU as it's mechanical. As it has no ECU it has no airbag light.

The 155 went up to 1997 and the GTV started in 1995, so a bit of overlap.
 

·
Registered
Joined
·
37,755 Posts
I want to know how they know the car has an airbag ECU ?

The 155 has a drivers airbag, but no ECU as it's mechanical. As it has no ECU it has no airbag light.

The 155 went up to 1997 and the GTV started in 1995, so a bit of overlap.


Mechanical airbag, How does that work? :lol:
 

·
Registered
Joined
·
30,067 Posts
Has a rod from the firewall to up behind the steering column, has a couple of kinks in it do it doesn't end up in your face on impact :lol: this triggers a self contained airbag charge inside the steering wheel. It's not even connected to the steering wheel heart like more modern alfas do the airbag and charge are separate.
 
1 - 20 of 39 Posts
Top