Alfa Romeo Forum banner

1 - 4 of 4 Posts
R

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Hi guys,

Just been reading the lastest topics and thought id post about my similar problem.
My injection light is on most of the time, only goes off on a really hot day :confused: .
I get backfires in my exhaust fairly often, some of which even cause the car to stall :( . Ive noticed loads of possible problems posted on here and dont know where to start to be honest. I think the lambda could be the problem as warmer weather seems to help the problem, anyone got any ideas??
Ive recently had my Cat replaced too so im worried its getting damaged :(

Thanks !

Rob
 

·
Registered
Joined
·
447 Posts
If you're not sure about your Lambda you'd start looking there, you can also put some injector cleaning fluid in but I think you should let the dealer do an overal check 'cause it could even be a valve or so..

One thing I don't inderstand, you've got your cat replaced and now you're worried it's getting damaged???? :confused:
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Da Londo

The Cat will be damaged if the car is not running right and pumping unburnt fuel onto the "honeycomb" inside it which converts the nasty emissons into furry animal friendly gases.

There ar several things that could be wrong with your car, lambda, temp sensor, plugs, leads.....etc etc!! Da Londo is right, get it checked by a competant injection specialist. BTW, dont think ambient temperature will affect the injector light....unless there's a water ingress problem perhaps :confused:

wrinx
 

·
Registered
Joined
·
447 Posts
Ah yes, I understand, I was thinking he was worried it was his cat that produced the backfire.
 
1 - 4 of 4 Posts
Top