Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3,483 Posts
Discussion Starter #1
I'm just about to take mine for its not mandatory MoT but when checking round found both main beams not working (dips do); the warning light comes on and the relay (fitted them a few years ago) clicks, all fuses OK but when I checked the power out to the mains from the relay it was showing zero on my meter, I have to assume the relay has gone faulty even tho it clicks, anyone suggest anything else may be wrong before I go buy another one?
thanks
 

·
Registered
Joined
·
1,705 Posts
Assuming you have separate relays for the main and the dipped, could you just switch one for the other and see what happens?
 

·
Registered
Joined
·
3,483 Posts
Discussion Starter #3
Thanks Nick - good idea, I've got a bigger problem now , it failed the mot but not on the lights.....one of the rear wheel bearings is running rough so I'm going to have to get it done by the only mechanic I trust (apart from me) - i just don't have the time or inclination at the moment
 

·
Registered
Joined
·
1,099 Posts
Aup Martin.. Kind words about my skills... unfortunately I too am really busy at the minute...:cheeky::cheeky::cheeky::cheeky:

IF the car is MOT exempt and you have put it through a test which then fails are you still ok to drive the car?


Thanks Nick - good idea, I've got a bigger problem now , it failed the mot but not on the lights.....one of the rear wheel bearings is running rough so I'm going to have to get it done by the only mechanic I trust (apart from me) - i just don't have the time or inclination at the moment
 

·
Registered
Joined
·
3,483 Posts
Discussion Starter #5
Aup Martin.. Kind words about my skills... unfortunately I too am really busy at the minute...:cheeky::cheeky::cheeky::cheeky:

IF the car is MOT exempt and you have put it through a test which then fails are you still ok to drive the car?
Awww shucks Rod, can't you fit it in somewhere..., yes I did wonder whether its better to leave it "run out" or failed but as it doesn't need an MoT is it relevant? - maybe i should have just just got it done without logging it, anyhoo its not going to be driven until the bearings (on order) are done, it also failed on emissions (HC)... again....but that's only a case of leaning it off while its on their diagnostic machine, funnily enough the CO2 was really low. Everything else was fine so i'm pleased I had it done and will continue to do so
 
  • Like
Reactions: roony

·
Registered
Joined
·
3,483 Posts
Discussion Starter #6
It was the relay, still clicks but don't work, booked in for bearing Thursday, pass Friday hopefully...
 

·
Registered
Joined
·
1,705 Posts
Interesting. They are pretty basic things when you open them up so not much to go wrong.

Good luck on Friday.

Will we see you at Cotswold Alfa day? My better half and I will be in the silver 916, reg. ****NMF
 

·
Registered
Joined
·
3,483 Posts
Discussion Starter #8
Interesting. They are pretty basic things when you open them up so not much to go wrong.

Good luck on Friday.

Will we see you at Cotswold Alfa day? My better half and I will be in the silver 916, reg. ****NMF
Cheers Nick - not sure yet as I've got an airport run to do (although i have a reserve if i really need) and my navigator is on the plane that is arriving at midday ..., definitely doing NAD tho
 
1 - 8 of 8 Posts
Top