Alfa Romeo Forum banner

1 - 13 of 13 Posts
R

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Just wanted to check if any 2.4 owners have experienced this.

When cruising in 5th or 6th gear on Motorways around 50/60 mph and engine rpm is around 1200 or lower I've noticed a slight juddering when I begin to accelerate back up-to 70mph.
Any other time it's fine, car has done 16k miles
Could it be the DMF or is this a Alfa "feature".
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Its a bit of an ask to accelerate from 1200 rpm in top.
Previous car was a 147 JTD and was OK maybe because the Brera is a much heavier car I need to change down more often and not be so lazy:thumbs:
 

·
Registered
Joined
·
538 Posts
ITs the DPF! Mine does it a LOT. My car is a lot worse than yours by the sounds of it but its pretty common on this forum.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #5
ITs the DPF! Mine does it a LOT. My car is a lot worse than yours by the sounds of it but its pretty common on this forum.
There has been a lot of banter in the tuning section on the benefits of removing the DPF,
so this could be another reason in favour of deleting it
 

·
Registered
Joined
·
538 Posts
There has been a lot of banter in the tuning section on the benefits of removing the DPF,
so this could be another reason in favour of deleting it
I would rip it off in a second given the chance. Its been nothing but trouble from day 2 (literally).

My fuel economy would probably double with it off too.
 

·
Registered
Joined
·
972 Posts
Mine did this when I first got it (second hand); although I noticed it in 5th/6th at around 1500 revs when accelerating. A Dose of Millers with each refuel (plus a regular Italian tune-up) have pretty much cured mine. I've always assumed it was down to the EGR getting a bit clogged; but I guess equally, it could be the DPF.
 

·
Registered
Joined
·
967 Posts
I get the judder when trying to maintain a steady speed during a regen :eek: It's 'normal' according to the dealer :rolleyes: I'm not sure I would try accelerating in 6th gear from 50mph, drop it down into 3rd and give it some welly :cool:
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #9
Just wanted to check if any 2.4 owners have experienced this.

When cruising in 5th or 6th gear on Motorways around 50/60 mph and engine rpm is around 1200 or lower I've noticed a slight juddering when I begin to accelerate back up-to 70mph.
Any other time it's fine, car has done 16k miles
Could it be the DMF or is this a Alfa "feature".
You dont say if you have a 200 or 210 version

If its a 200, IMHO, its driver error; the torque simply wont allow you to drive it like that. The motor in mine wont pull really before 1500 rpm. I understand the 210'S have more bottom end grunt. Its not an Alfa feature, many cars would struggle with what you are trying to achieve :)
 

·
Registered
Joined
·
7,179 Posts
50 MPH is 1400 RPM in my (210) in top, it will pull from lower, in fact at idle in sixth, it does just over 30mph, so you must be trying to pull from about 40mph, mine will usually do it, but its not for the mechanically sympathetic!
 

·
Registered
Joined
·
972 Posts
As CJ Romeo says above; not for the mechanically sympathetic.....but my 200 will pull cleanly (and suprisingly strongly) from about 1200 revs; and is blowing 0.8bar by 1400 revs. Certainly wouldn't recommend putting too much pressure on the accelerator at 1200 revs though :thumbs:
 

·
Registered
Joined
·
1,764 Posts
You dont say if you have a 200 or 210 version

If its a 200, IMHO, its driver error; the torque simply wont allow you to drive it like that. The motor in mine wont pull really before 1500 rpm. I understand the 210'S have more bottom end grunt. Its not an Alfa feature, many cars would struggle with what you are trying to achieve :)
^^^^What he says :)^^^^

You're catching the turbo out at those revs, as it needs to spool up at around 1800-2k, before pulling hard!

Change down a gear and stop being lazy lol, it's a 5 cylinder engine and needs a few more revs :thumbs:
 

·
Registered
Joined
·
295 Posts
What about when your cruising at about 60-70mph and you feel a sudden loss of power / judderiness! What's all that about!
The car makes you drop a gear, from 6th to 5/4th and back up again to 6th...

Then it's normal again after a few minutes...

Weird! :((
 
1 - 13 of 13 Posts
Top