Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all,

I have a problem on my Alfa Romeo GT Q2 Jtdm 57 plate. I was accelerating up a hill and the power completely cut out and when i pulled over i couldnt rev past about 3000 revs and the engine felt like it was about to jump out the bonnet.

After completing an extremely dangerous 3 point turn (and scratching my alloy:mad:) i managed to roll it down best part of the hill. After trying to push it the rest of the way home (about half a mile) the hamstrings started giving in and the people i called to help were close to death so i decided to try and start it again (after about 15-20mins from when it first cut out). It turned over fine and was reving like normal...it almost cut out again while driving but shifted down a gear and seemed to be ok.

Tried turning it on and reving while stationary on my drive and it was reving fine (but i didnt risk driving it).

Other bits of info that might help...On my last MOT my mechanic suggested changing the cam belt as he was hearing a noise from that area. My drive to work is about 40 miles round trip and consists of motorway for about half then intermitant traffic for the remainder (so it gets a good run). Its got 43k miles. I was into the 1st minute of the journey when hill-gate occured.

Any help would be much appreciated (sorry for the life story...im still venting).
 

·
Registered
Joined
·
2,900 Posts
Or crankshaft sensor, it gets to a point where it heats up and fails, after cooling it tends to work.

Couldn't edit earlier post, noticed it's a jtdm, might not have a cam sensor
 
1 - 4 of 4 Posts
Top