Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter #1
Yes another thread but my scenario is a little different.

I have a 2004 147 GTA with 33,000mls.

I have just done its annual oil change with Selenia racing oil and installed an alfa oil filter. This was done last week and i have drove it perhaps once or twice since then.

However yesterday i drove it a good 20miles, sat in the car with the engine off for about 20mins and the radio on and the radio cut out? Turned the car back over and everything was fine. Returned to the car about 20mins later to drive back and then the 'Low engine oil pressure warning' came on the dash computer.

Engine oil temp was fine, no strange knocking and gently revved it through the range. As i was stranded i drove it back the 20miles at a steady 50mph with no changes in the oil heat and no strange engine knocking noises etc...

I have taken the car to my garage who are going to look at it this morning, but yesterday the oil was checked and it appeared fine?

Solution? Check oil levels again and put more oil in? or could it be that the sensors needs replacing? some threads ive read say that it could be the battery?

The car has been maintained ridicolously and has never really been pushed hard at all..Im worried that it may be the oil pump or that the engine is about to go bang?

Help? :(
 

·
Registered
Joined
·
107 Posts
Discussion Starter #3
my father did, who has his own car bodyshop. that wa yesterday after it has been driven and he is checking again this morning. he is ordering a sensor to see whether that may be it.

failing that ££££££££££££££££
 

·
Registered
Joined
·
2,140 Posts
I had this warning when I stalled mine a few months back but it's been fine since then. Would be interesting if it does turn out to be a sensor issue for you. I would have thought an error code would come up if the sensor is dodgy though?
 

·
Registered
Joined
·
107 Posts
Discussion Starter #6
we plugged into the computer and it has came up with a failed sensor reading. we have ordered a new one and it will be getting fitted soon.

everything crossed that thats all it is!
 
1 - 9 of 9 Posts
Top