Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
The last 30 mins of a 6 hr motorway drive today has me puzzled as the car developed a loud click every time I press throttle pedal
Seems to be coming from the area behind temperature control
Lift off pedal to slow down then as soon as I press down again CLICK
this isn't a quiet little noise it's a very loud one
Any thoughts much appreciated
Car has been faultless apart from the last half hour
It's a 159 2.4 2006
Thanks


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
43 Posts
Discussion Starter #2
Well been a few days now and still have a noise only now instead of a click it's more like something sliding into place
Happens when lifting off throttle pedal and again when pressing down on it
Could it be something on top of gearbox as it seems to be coming from somewhere between gear stick and heater controls
In Portsmouth on a course and got another 6 hr drive home Friday night
Thanks


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
565 Posts
It sounds a bit DMF'y - rock the car backwards and forwards in gear to see if you can trace it a bit further in the engine bay
 

·
Registered
Joined
·
43 Posts
Discussion Starter #5
It sounds a bit DMF'y - rock the car backwards and forwards in gear to see if you can trace it a bit further in the engine bay


Thanks for reply
Back down to Portsmouth this weekend
and have no choice but to use the car no other available - indie I use has lot of staff on holiday so can't look at the car for at leat a week
Never had a slipping clutch before the symptoms now are
Hit close to 3000rpm in 5th or 6th gear and then it drops to 2000rpm and boost also drops sharply
Push throttle and will not go above 2200rpm but drop into 4th and all ok again
Always have this load clicking noise when lifting/pressing throttle


Sent from my iPhone using Tapatalk
 
1 - 5 of 5 Posts
Top