Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Hi guys! yesterday have installed free flow pipes instead of back box silencer( car was remapped before this mod) and also have second cat replaced with free flow few months ago,so before installation of free flow instead of back box silencer car was more lively and more torque as well,so do i need to remap again to sort it out? Thanks :paranoid:
 

·
Registered
Joined
·
4,265 Posts
Probably - the car has been mapped with the standard exhaust in place, you should always map AFTER doing exhaust mods really. Soz if you paid out loads and you gotta pay out loads again.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #3
Probably - the car has been mapped with the standard exhaust in place, you should always map AFTER doing exhaust mods really. Soz if you paid out loads and you gotta pay out loads again.
Yes you right mate,my best option for now is leave this issue until i have all mods done,then custom map finally;)
 

·
Registered
Joined
·
562 Posts
As your car is turbo it most likely some sensor fault. Have you disconnected anything and might be forgotten to put it back? (or damaged a wire?).

I had a 1.9 JTDM which had lust it's exhaust right after the turbine.... and that thing was instant on Spool and power (just a tad to noisy). There is simply no way that a free flow exhaust will seriously hamper a JTD engine without a remap - there must be some sensor info missing for the ecu so it's in some kind of limp mode. (or your free flow stuff is not free flow)
 

·
Registered
Joined
·
36 Posts
Discussion Starter #7
Thanks guys;) yes my free flow is a proper freeflow with 72mm pipes straight from main cat,there is only one thing left for this mod -replace main cat with downpipe and custom map on dyno;)
 
1 - 7 of 7 Posts
Top