Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
Big hose below turbo looks oily and dirty whilst everything else nearby in engine bay looks clean.

Anybody any experience of what may be going on.

I posted last week with uneven accelaration through 3,000 rpm on partial throttle (ok with plenty of foot down). Could be related?
 

·
Registered
Joined
·
219 Posts
Big hose below turbo looks oily and dirty whilst everything else nearby in engine bay looks clean.

Anybody any experience of what may be going on.

I posted last week with uneven accelaration through 3,000 rpm on partial throttle (ok with plenty of foot down). Could be related?
I do not think they are related, I closed egr and problem gone...

regarding the oil...

it is usual to get some oil from the black air pipe near the turbo under the clamp.
you can tighten the clamp
check oil level and see if it is over the max reading!
 

·
Registered
Joined
·
1,379 Posts
I raised the same question last week, i have clumps of oil on the bottom pipe and the side pipe is also quite oily along with one of the smaller pipes near top of the engine... oil level also dropped but its due a change anyway, have asked them to look at it when it goes in this Friday...
 

·
Registered
Joined
·
5,064 Posts
I'm on my third alfa with the 1.9jtdm engine, and they have all had the same "clumps" of oil and debris on the lower turbo pipe. No signs of a leak or split. It just seems to be an accumulation of gunk over the years and miles.

I'm not worried about it. Oil level stays the same.
 
1 - 5 of 5 Posts
Top