Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hi all
I just joined here and am looking for a 156 sportwagon.
I have seen one, a 2003 1.8 turismo but have one niggling queston. The engine management light stays on prior to the engine firing. It goes out when you are driving but I think it is a sign of faulty sensor, or another problem.
The dealer in questions tells me that it is just because it ran out of petrol not long ago and is nothing to worry about.

Am I being paranoid? the rest of the car looks and drives fine....... brakes are a bit soft but he is allowing for that in the price.

What do you think ? Can running out of petrol cause the management light (small yello pic of engine) to remain lit

Cheers

Bernie
 

·
Registered
Joined
·
4,646 Posts
the EML will stay on when the engine is not running, once the engine starts it should cancel.
 

·
Banned
Joined
·
9,721 Posts
The engine management light stays on prior to the engine firing. It goes out when you are driving but I think it is a sign of faulty sensor, or another problem.
The dealer in questions tells me that it is just because it ran out of petrol not long ago and is nothing to worry about.
The light is telling you that the engine is picking up a problem, in this case, that the key is at MAR and the engine is not running, which is what you'd expect, nw when you start the car the light goes out, well that means that the ECU is happy that the key is at MAR with the engine running and that all the sensors are giving good figures.

If your dealer feels the need to fabricate an excuse for a non-existent fault then I would have to scrutinise thier integrity.
 

·
Registered
Joined
·
1,109 Posts
Got to agree with smaky there.
That dealer is full of (cant say or i will get in to trouble)
 

·
Registered
Joined
·
4,646 Posts
I bought a very nice S/w on Sunday in North Belfast.

01, 1.8TS, 78k miles, nice alloys, leather interior

Could sell it back to you if you're interested.

Still on NI plates
 
J

·
Guest
Joined
·
0 Posts
Hi all
I just joined here and am looking for a 156 sportwagon.
I have seen one, a 2003 1.8 turismo but have one niggling queston. The engine management light stays on prior to the engine firing. It goes out when you are driving but I think it is a sign of faulty sensor, or another problem.
The dealer in questions tells me that it is just because it ran out of petrol not long ago and is nothing to worry about.

Am I being paranoid? the rest of the car looks and drives fine....... brakes are a bit soft but he is allowing for that in the price.

What do you think ? Can running out of petrol cause the management light (small yello pic of engine) to remain lit

Cheers

Bernie
Bernie, welcome to AO

the SW is a great car, i have a 2.0 Lusso...

The engine management light should go out once the engine has started, if it is on with the engine running then there is possible an issue and it either need to be looked at before the sale or you could use it as a way of haggling the price down....but be warned no one will be able to give you a cost to fix until they have plugged diagnostic equipment into the car
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
Thanks for all your replies, its very helpful.
I went back to the dealer for another drive ( is starting to get pissed off now, lol 2nd time driving it) and I was wrong! - the eml stays on while driving though the car pulls well through the rev range (within reason) without any hesitation or stuttering.
I could use the eml issue as a means of getting it a bit cheaper.

Sears - great links you got there - I spent ages going through them.
I am narrowing down what version I want as I get more info.
Hopefully a face-lifted 2002/2003 2 litre jts or good 1800 for under 3K
Would love a v6 but they seem to be as rare as hens teeth. but thanks anyway Sears.
This dealer is asking 2700 for this 2003 turismo.
Cheers guys - I will let you knwo when I get something
 

·
Registered
Joined
·
1,109 Posts
Thanks for all your replies, its very helpful.
I went back to the dealer for another drive ( is starting to get pissed off now, lol 2nd time driving it) and I was wrong! - the eml stays on while driving though the car pulls well through the rev range (within reason) without any hesitation or stuttering.
I could use the eml issue as a means of getting it a bit cheaper.

Sears - great links you got there - I spent ages going through them.
I am narrowing down what version I want as I get more info.
Hopefully a face-lifted 2002/2003 2 litre jts or good 1800 for under 3K
Would love a v6 but they seem to be as rare as hens teeth. but thanks anyway Sears.
This dealer is asking 2700 for this 2003 turismo.
Cheers guys - I will let you knwo when I get something

Walk away from it. it has issues.
And you have to ask yourself why the dealer has not sorted it.:tut:
 

·
Registered
Joined
·
16 Posts
Discussion Starter #9
yeah crespo, i think you are right.
Trouble is........ my 'previous' car (subaru wagon) was stolen 2 weeks ago and I have decided on an Alfa Sportwagon to replace it.
Guess I am just impatient - thanks for your advice:)
 

·
Registered
Joined
·
16 Posts
Discussion Starter #11
Cheers for that, Iain
I am going to give this particular car a miss - just too many niggly things not quite right. Noticed slightly different shade of red around the front bumper too.
Dealer said it was just the colour fading but I am fairly sure it was hit at some time in the past.
 
1 - 11 of 11 Posts
Top