Alfa Romeo Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
I have owned a few Alfa's over the last 20 years and have just bought myself another 156 (the last one got a bit squashed and was never the same after they repaired it.

I have a 2000 156 Selespeed at present which is what I have wanted for ages but have not had a good experience with this one as the day after I bought it the light came on for the gearbox and it would not engage a gear. The cause a faulty Hydraulic pump which was replaced and the box has been fine since. A few weeks after that the exhaust flexible couple gave out and although the sound was immense it was a bit on the illegal side!!. went to change it and found that this coupling is on the front manifold section with the catalytic converters fix to it so loads of money to change. Lucky enough found a local exhaust specialist who replaced the flex and all fine after. Have now developed not quite a miss fire but a jolting when cold, which is now starting not to clear when warm time for a visit to the Alfa garage me thinks.

All my previous Alfa’s have been great with no problems, wish I had never sold my Sud though (1350 TI rocket) but 4 doors were needed at the time. a 164 3.0 Lusso and a 1.8TS 156 later and I am on to the selespeed, I do like to keep my Alfa's as long as possible but they have been relegated to 2nd cars now.
 

·
Registered
Joined
·
785 Posts
Welcome aboard.
 

·
Administrator
Joined
·
60,075 Posts
Hi Duvlin, glad you found us, sounds like you know your way around alfa's:) Enjoy the site and all it's interesting threads. Cheers:)
 

·
Registered
Joined
·
6,451 Posts
Hello and welcome....sorry to hear you've had one or two probs, but as a confirmed Alfista I'm sure you'll forgive her :D
 

·
Registered
Joined
·
821 Posts
duvlin said:
Have now developed not quite a miss fire but a jolting when cold, which is now starting not to clear when warm time for a visit to the Alfa garage me thinks.
Welcome to the forum.

The jerkiness you mention when cold sounds like quite a common problem on older 156's (mine had it). It is probably the MAF and/or Lambda sensors. If so, you should notice it more under heavy acceleration and it will progressively worsen.

MAFs are quite easy to come by and can be changed easily, but the Lambda sensor is about £150 + VAT from an Alfa/Fiat dealer (exc. fitting).
 

·
Registered
Joined
·
62 Posts
Discussion Starter #13
Thanks for all the welcome's and I hope to be a regular visitor. Thanks also for the advise re the jerkiness shall give it a try.
 

·
Registered
Joined
·
43,564 Posts
Hello and Welcome !! :)
 
1 - 14 of 14 Posts
Top