Alfa Romeo Forum banner
1 - 10 of 10 Posts
G

·
Discussion Starter · #1 ·
I have a problem with the lighting of the center console in my alfa 145 (1996). The lights for heating suddenly do not work anymore. Ashtray light works though.
Can anybody give me a hint how I can fix that?
Any help appreciated

Thanx!
 

·
Registered
Joined
·
1,306 Posts
<blockquote><font size="1" face="Verdana, Helvetica, sans-serif">quote:<hr /><font size="1" face="Verdana, Helvetica, sans-serif">Originally posted by hartwerk:
<strong>I have a problem with the lighting of the center console in my alfa 145 (1996). The lights for heating suddenly do not work anymore. Ashtray light works though.
Can anybody give me a hint how I can fix that?
Any help appreciated

Thanx!</strong><hr /></blockquote><font size="1" face="Verdana, Helvetica, sans-serif">There blubs behind the Knobs, pull them off and there somewhere under there wink

HTH
 

·
Registered
Joined
·
3,257 Posts
Yep - I had 3 dash bulbs go all in one weekend.
Pull the knobs off - then there screws behind them, and one additional screw towards the steering column side.

The bulbs are there just waiting to be pulled out! I forget which size & rating they are
 
G

·
Discussion Starter · #4 ·
:) Ah, good, i was going to ask if the screws have to go or not. Thanks, will try that tomorrow.
 

·
Registered
Joined
·
3,257 Posts
<blockquote><font size="1" face="Verdana, Helvetica, sans-serif">quote:<hr /><font size="1" face="Verdana, Helvetica, sans-serif">Originally posted by hartwerk:
<strong> :) Ah, good, i was going to ask if the screws have to go or not. Thanks, will try that tomorrow.</strong><hr /></blockquote><font size="1" face="Verdana, Helvetica, sans-serif">Yes they do - only about 3/4 crossheads. You may need to remove the blank panel on the passenger side as I think there is a screwunder that one. Maybe...
 
G

·
Discussion Starter · #6 ·
ok, tried it today and had no success :(

took the knobs off, took the screws out, and realized that those screws do not hold the black front panel. (The one where the "icons" are painted on)...

So... again... any help?

Thnx
 

·
Registered
Joined
·
3,257 Posts
Im sure they do...

I think it is also clipped so it needs some leverage, plus there is one screw on the face of the panel which requires you to pop the screw cover out. I think you need to remove the adjacent panel on the passenger side (where the airbag connector is) as I think there may be a screw for the panel under there..
 
G

·
Discussion Starter · #8 ·
Pop off the trim panel that is curved between the airbag unit and the heater control panel, it is only held in by push on clips a slim screwdriver should do the job.It pull forward towards the seats rather than left to right. You should then see I think two screws two holding the icon panel on, remove them.

Then on the panel with the icons itself you will see a rubber plug, remove that and behind it there should be another srcew, remove that. Then remove the heater knobs as described previously, remove the icon panel and you should have access to all the bulbs. Assembly is the reverse.

Hope this helps.
 
1 - 10 of 10 Posts
Top